View Issue Details

IDProjectCategoryView StatusLast Update
0020442Packages-public2011-10-17 11:34
ReporterTommi Prami Assigned ToFelipe Monteiro de Carvalho  
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
Product Version0.9.31 (SVN) 
Fixed in Version0.9.31 (SVN) 
Summary0020442: PAge Control crashes into EReadError of OnPageChanged even on WinCE
Description* Exception EReadError with message "Error reading pageState.OnPageChanged: Unknown property: "OnPageChanged""

Same happens when I click the OnPageChanged event on a IDE (On an WinCE App, not tested otherwise)

 
Additional InformationLazarus 0.9.31 (Rev : 32778)
FPC 2.4.4
Pocket PC 6.5 Pro

(Provide more information later, if needed)
TagsNo tags attached.
Fixed in Revision32937
LazTarget0.99.0
WidgetsetWinCE
Attached Files

Relationships

related to 0019903 closedFelipe Monteiro de Carvalho Lazarus [patch] TPageControl.OnChange fires twice 

Activities

Vincent Snijders

2011-10-09 12:21

manager   ~0052794

Felipe, maybe we must add the removed event to the properties to skip to prevent such breakage?

Tommi Prami, see also http://wiki.lazarus.freepascal.org/Lazarus_0.99.0_release_notes#TCustomPageControl.2FTPageControl.OnPageChanged_were_removed

Tommi Prami

2011-10-09 15:57

reporter   ~0052802

Hello,

That Event is not used in any way. So where it is coming from then.

And tested with the Win32 version of the project also, with the same outcome.

From the mailing list :

"Event is not used in any way... And it is visible in the "Events list"...

And I checked the .lfm (the .dfm equivalent) and there was no trace of the Event also (I was thinking that maybe it is there and not in sync with code etc... "

Tommi Prami

2011-10-09 15:59

reporter   ~0052803

Hello,

And this must be Quite new "regression" because few revisions back it worked just fine...

.-Tee-.

Flávio Etrusco

2011-10-09 16:49

reporter   ~0052804

Last edited: 2011-10-09 18:17

That's why, despite hating accumulating legacy garbage, I proposed keeping the property... 0019903
It could be implemented as a write-only property, or read in DefineProperties, so that it doesn't show in the OI.

Felipe Monteiro de Carvalho

2011-10-12 09:19

developer   ~0052888

@Vincent

Do you know how works/where is this list of properties to skip?

Felipe Monteiro de Carvalho

2011-10-12 09:21

developer   ~0052889

@Tommi

Your IDE and LCL are desynchronized. Does it work if you update your IDE?

Vincent Snijders

2011-10-17 10:29

manager   ~0053084

I would search for RegisterPropertyToSkip in the LCL to get a lot of examples.

Felipe Monteiro de Carvalho

2011-10-17 11:34

developer   ~0053087

Thanks for the hint =) I implemented the property skip

Issue History

Date Modified Username Field Change
2011-10-09 10:27 Tommi Prami New Issue
2011-10-09 10:27 Tommi Prami Widgetset => WinCE
2011-10-09 12:21 Vincent Snijders LazTarget => 0.99.0
2011-10-09 12:21 Vincent Snijders Note Added: 0052794
2011-10-09 12:21 Vincent Snijders Assigned To => Felipe Monteiro de Carvalho
2011-10-09 12:21 Vincent Snijders Status new => assigned
2011-10-09 12:21 Vincent Snijders Target Version => 0.99
2011-10-09 15:57 Tommi Prami Note Added: 0052802
2011-10-09 15:59 Tommi Prami Note Added: 0052803
2011-10-09 16:49 Flávio Etrusco Note Added: 0052804
2011-10-09 18:17 Flávio Etrusco Note Edited: 0052804
2011-10-12 09:19 Felipe Monteiro de Carvalho Note Added: 0052888
2011-10-12 09:20 Felipe Monteiro de Carvalho Relationship added related to 0019903
2011-10-12 09:21 Felipe Monteiro de Carvalho Note Added: 0052889
2011-10-17 07:30 Felipe Monteiro de Carvalho Status assigned => feedback
2011-10-17 10:29 Vincent Snijders Note Added: 0053084
2011-10-17 11:34 Felipe Monteiro de Carvalho Fixed in Revision => 32937
2011-10-17 11:34 Felipe Monteiro de Carvalho Status feedback => resolved
2011-10-17 11:34 Felipe Monteiro de Carvalho Fixed in Version => 0.9.31 (SVN)
2011-10-17 11:34 Felipe Monteiro de Carvalho Resolution open => fixed
2011-10-17 11:34 Felipe Monteiro de Carvalho Note Added: 0053087