View Issue Details

IDProjectCategoryView StatusLast Update
0020475LazarusWidgetsetpublic2020-04-01 10:51
ReporterLuiz Americo Assigned ToZeljan Rikalo  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionnot fixable 
Summary0020475: LM_CLEAR, LM_CUT, LM_PASTE and LM_COPY are not sent by Qt
DescriptionThe mentioned messages are not sent by TEdit, TMemo and TComboBox controls in Qt widgetset.

The messages LM_CLEAR, LM_CUT, LM_PASTE should be sent before the text is changed and must be a mechanism to abort the action (under Delphi not calling inherited but could be changing the Msg.Result to 1)
TagsNo tags attached.
Fixed in Revision
LazTarget-
WidgetsetQT, QT5
Attached Files

Relationships

related to 0020394 resolvedLuiz Americo Regression: TDBEdit looses information 

Activities

Zeljan Rikalo

2011-10-15 20:11

developer   ~0053027

What about is LM_CLEAR ? Delete selected text ?
Anyway, I cannot catch anything from actions or any event over context menu actions ... it's just executed ...events from keyboard can be stopped (eg. Ctrl+C, Ctr+V etc) ... problem is default context menu atm.

Zeljan Rikalo

2011-10-16 18:43

developer   ~0053057

ok, seem that there's hard way ...
1.Override default shorcuts in TQtLineEdit class with
 our actions.
2.Override default context menu in TQtLineEdit class with
 our actions.

Luiz Americo

2011-10-16 22:52

developer   ~0053062

> What about is LM_CLEAR ? Delete selected text ?
Under windows/Delphi, yes.

Under Qt i dont know if is the same behavior. You can look what Clear action of default context in Qt does. According to Qt docs method clear removes all text. Not big deal if is different.

Zeljan Rikalo

2011-10-22 14:49

developer   ~0053277

Added target 1.0 because I don't know how much free time I'll have to fix this.

Zeljan Rikalo

2011-10-23 08:07

developer   ~0053316

I've added lcReceivesLMClearCutCopyPasteReliably = LCL_CAPABILITY_NO in r33037
until this issue is fixed.

Zeljan Rikalo

2012-02-05 15:35

developer   ~0056518

Postponed, since there's no mechanism to intercept clear,cut and paste with qt before it actually happens.Maybe unfixable.

Zeljan Rikalo

2014-09-12 08:47

developer   ~0077122

No idea how to fix this, since those ops are not part of qt event system, so no way to handle it in LCL way. Maybe somebody have some idea or patch, so that's why I won't close this issue atm.

Zeljan Rikalo

2020-04-01 10:51

developer   ~0121823

Qt/Qt5 library does not have implementation for LM_CLEAR,CUT,PASTE,COPY , so no way to implement it for LCL Qt/Qt5. Marked as not fixable.

Issue History

Date Modified Username Field Change
2011-10-13 02:24 Luiz Americo New Issue
2011-10-13 02:24 Luiz Americo LazTarget => -
2011-10-13 02:24 Luiz Americo Widgetset => QT
2011-10-13 09:39 Vincent Snijders Assigned To => Zeljan Rikalo
2011-10-13 09:39 Vincent Snijders Status new => assigned
2011-10-13 14:39 Felipe Monteiro de Carvalho Relationship added related to 0020394
2011-10-15 20:11 Zeljan Rikalo Note Added: 0053027
2011-10-16 18:43 Zeljan Rikalo Note Added: 0053057
2011-10-16 22:52 Luiz Americo Note Added: 0053062
2011-10-22 14:49 Zeljan Rikalo LazTarget - => 1.0
2011-10-22 14:49 Zeljan Rikalo Note Added: 0053277
2011-10-23 08:07 Zeljan Rikalo Note Added: 0053316
2012-02-05 15:35 Zeljan Rikalo LazTarget 1.0 => post 1.2
2012-02-05 15:35 Zeljan Rikalo Note Added: 0056518
2013-09-03 12:07 Martin Friebe LazTarget post 1.2 => 1.4
2014-09-12 08:47 Zeljan Rikalo LazTarget 1.4 => post 1.4
2014-09-12 08:47 Zeljan Rikalo Note Added: 0077122
2020-04-01 10:51 Zeljan Rikalo Status assigned => resolved
2020-04-01 10:51 Zeljan Rikalo Resolution open => not fixable
2020-04-01 10:51 Zeljan Rikalo LazTarget post 1.4 => -
2020-04-01 10:51 Zeljan Rikalo Widgetset QT => QT, QT5
2020-04-01 10:51 Zeljan Rikalo Note Added: 0121823