View Issue Details

IDProjectCategoryView StatusLast Update
0020480LazarusIDEpublic2011-10-14 06:52
Reporterlingling Assigned ToVincent Snijders  
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionwon't fix 
Product Version0.9.30.1 (SVN) 
Summary0020480: always show the modal form
Descriptionwhen close the lazarus current project, it is always show a modal form , it is very hate,if it is like delphi,when close project,not show any modal form ,because the user is not want it.
TagsNo tags attached.
Fixed in Revision
LazTarget-
Widgetset
Attached Files

Relationships

duplicate of 0008097 closedMattias Gaertner Ability to Close Currently Open Project 

Activities

Vincent Snijders

2011-10-13 16:46

manager   ~0052942

I don't understand what you are talking about?

Can you provide steps to reproduce? Can you attach a screen shot of the 'modal form'?

Anton

2011-10-13 19:37

reporter   ~0052951

It's easy. Choose menu Project->Close Project, and modal form Project Wizard will appear.

Zeljan Rikalo

2011-10-13 21:27

developer   ~0052955

I suppose that Project cannot be nil (closed) so that's why Project Wizard pops up. What's the meaning of "Close project" action anyway ?
Close all files and then what ?

Vincent Snijders

2011-10-13 23:19

manager   ~0052961

I see what is meant. This is by design. If you don't want a dialog, just quit lazarus or choose new project.

lingling

2011-10-14 02:41

reporter   ~0052964

yes, i know how to close it.but it is design is hate, delphi was not this form,but all users use it very will!

Flávio Etrusco

2011-10-14 03:54

developer   ~0052965

This is not a bug, but a minor "feature request".
Anyway it has been discussed a few times already on the mailing list; it's an extensive change and none of the developer intends to undertake it just for the cosmetics (but it'll probably be taken care of when/if project groups get implemented). Patches are welcome. Otherwise just use a dummy project.

Vincent Snijders

2011-10-14 06:52

manager   ~0052967

OK, then instead of "no change required", I set it to resolved with "won't fix". Maybe that is clearer.

Issue History

Date Modified Username Field Change
2011-10-13 12:19 lingling New Issue
2011-10-13 16:46 Vincent Snijders LazTarget => -
2011-10-13 16:46 Vincent Snijders Note Added: 0052942
2011-10-13 16:46 Vincent Snijders Status new => feedback
2011-10-13 19:37 Anton Note Added: 0052951
2011-10-13 21:27 Zeljan Rikalo Note Added: 0052955
2011-10-13 23:19 Vincent Snijders Relationship added duplicate of 0008097
2011-10-13 23:19 Vincent Snijders Duplicate ID 0 => 8097
2011-10-13 23:19 Vincent Snijders Status feedback => resolved
2011-10-13 23:19 Vincent Snijders Resolution open => no change required
2011-10-13 23:19 Vincent Snijders Assigned To => Vincent Snijders
2011-10-13 23:19 Vincent Snijders Note Added: 0052961
2011-10-14 02:41 lingling Status resolved => assigned
2011-10-14 02:41 lingling Resolution no change required => reopened
2011-10-14 02:41 lingling Note Added: 0052964
2011-10-14 03:54 Flávio Etrusco Note Added: 0052965
2011-10-14 06:52 Vincent Snijders Status assigned => resolved
2011-10-14 06:52 Vincent Snijders Resolution reopened => won't fix
2011-10-14 06:52 Vincent Snijders Note Added: 0052967
2011-10-14 06:52 Vincent Snijders Duplicate ID 8097 => 0