View Issue Details

IDProjectCategoryView StatusLast Update
0020493LazarusLCLpublic2020-10-20 21:03
Reportersilvioprog Assigned ToZeljan Rikalo  
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version0.9.30.2RC1 
Target Version0.9.30.2 
Summary0020493: OnExit called in OnEnter
DescriptionHi,

Steps to reproduce the error:

1. Open the demo in attached (test.zip);
2. Run the demo (F9);
3. When running, change to TabSheet2;

Screenshot with the error in attached.

Thx.

ps.:

My environment:

Lazarus 0.9.30.2RC1 r32563 FPC 2.4.4

openSUSE 11.4 with KDE
Additional InformationThe error ocourrs only in Linux. In Windows (XP or 7) is OK.
TagsNo tags attached.
Fixed in Revision33018
LazTarget0.99.0
WidgetsetGTK 2, QT
Attached Files

Relationships

related to 0037942 new TPageControl: TabStop, TabSwitch Focus and Keyboard TabSwitch 

Activities

2011-10-16 02:01

 

test.zip (2,553 bytes)

2011-10-16 02:03

 

snapshot.png (108,741 bytes)   
snapshot.png (108,741 bytes)   

Zeljan Rikalo

2011-10-16 08:52

developer   ~0053038

I cannot confirm this ... it does not happen here.
What's your laz version ?

silvioprog

2011-10-16 23:35

reporter   ~0053063

Current release version: Lazarus 0.9.30.2RC1 r32563 FPC 2.4.4. (Qt or GTK, the error appears in both).

Zeljan Rikalo

2011-10-17 07:02

developer   ~0053067

hm that's weird

Zeljan Rikalo

2011-10-21 13:19

developer   ~0053233

Must be confirmed and fixed or resolved if no bug before 0.9.30.2 !

Juha Manninen

2011-10-21 18:12

developer   ~0053247

Last edited: 2011-10-21 18:42

Confirmed with fixes_0.9.30.1 and FPC 2.4.4 on OpenSuse 11.4 Linux + GTK2, running under VirtualBox.
What more, I can also reproduce it with Lazarus trunk in the same environment.
On Windows it works correctly.
So, this is clearly not an issue of fixes_0.9.30.1 but something else. Why others can't reproduce it on Linux, I don't know.
I will set the target back to 0.99.

Juha Manninen

2011-10-21 18:51

developer   ~0053249

Silvio, could you also test with Lazarus trunk using the same environment.

Vincent Snijders

2011-10-21 19:32

manager   ~0053252

LazTarget should be 0.9.30.2, if the issue does not exist in 0.9.30.

LazTarget must be 0.9.30.2, if the issue does not exist in 0.9.30 and does not exist in 0.9.31.

Zeljan Rikalo

2011-10-21 20:19

developer   ~0053255

I confirm that this bug exists ONLY with gtk2 in laz trunk, but not with qt.
@Silivio, are you sure that you can reproduce this with qt ?

silvioprog

2011-10-21 20:29

reporter   ~0053256

Yes,

I will create a Virtual Machine with Lazarus/FPC trunk to reproduce this error in Qt.

Zeljan Rikalo

2011-10-21 22:22

developer   ~0053265

I cannot reproduce this with trunk (Fedora 14, 32bit qt-4.7.4)

Zeljan Rikalo

2011-10-22 13:13

developer   ~0053272

Please test with TRUNK and close if ok.
Unfortunatelly we cannot fix it for 0.9.30.2 since there was many changes about TabControl in trunk.
As workaround for 0.9.30.XX (gtk2), disconnect OnExit() of all controls on TTabSheet, and connect it again in OnShow() event of tab.
I cannot reproduce it with qt in any version.

silvioprog

2011-10-22 19:22

reporter   ~0053288

I cannot install Lazarus trunk on my openSUSE (in Virtual Machine).

You could send me a patch to I apply in my RC1 copy?

Zeljan Rikalo

2011-10-22 19:45

developer   ~0053289

@Silvio
1.That patch cannot be applied to RC1 since there was many changes about TCustomTabControl (it's renamed).
2.You can get patch here
http://svn.freepascal.org/cgi-bin/viewvc.cgi?view=rev&root=lazarus&revision=33018

silvioprog

2011-10-23 18:15

reporter   ~0053332

Sorry guys, now I saw that my Lazarus was compiled for GTK. ^^'

I thought that being in an environment in Qt, the Lazarus was already compiled for Qt.

After compile Lazarus to Qt, I saw that the problem did not really exist in it.

After this fix the problem was solved for GTK.

Thx.

Issue History

Date Modified Username Field Change
2011-10-16 02:00 silvioprog New Issue
2011-10-16 02:00 silvioprog Widgetset => GTK 2, QT
2011-10-16 02:01 silvioprog File Added: test.zip
2011-10-16 02:03 silvioprog File Added: snapshot.png
2011-10-16 08:52 Zeljan Rikalo LazTarget => -
2011-10-16 08:52 Zeljan Rikalo Note Added: 0053038
2011-10-16 08:52 Zeljan Rikalo Status new => feedback
2011-10-16 23:35 silvioprog Note Added: 0053063
2011-10-17 07:02 Zeljan Rikalo Note Added: 0053067
2011-10-21 13:19 Zeljan Rikalo LazTarget - => 0.99.0
2011-10-21 13:19 Zeljan Rikalo Note Added: 0053233
2011-10-21 13:28 Vincent Snijders LazTarget 0.99.0 => 0.9.30.2
2011-10-21 13:28 Vincent Snijders Target Version => 0.9.30.2
2011-10-21 18:12 Juha Manninen Note Added: 0053247
2011-10-21 18:12 Juha Manninen Status feedback => confirmed
2011-10-21 18:38 Juha Manninen Note Edited: 0053247
2011-10-21 18:42 Juha Manninen Note Edited: 0053247
2011-10-21 18:43 Juha Manninen LazTarget 0.9.30.2 => 0.99.0
2011-10-21 18:51 Juha Manninen Note Added: 0053249
2011-10-21 19:32 Vincent Snijders Note Added: 0053252
2011-10-21 20:19 Zeljan Rikalo Note Added: 0053255
2011-10-21 20:29 silvioprog Note Added: 0053256
2011-10-21 22:22 Zeljan Rikalo Note Added: 0053265
2011-10-22 09:11 Zeljan Rikalo Status confirmed => assigned
2011-10-22 09:11 Zeljan Rikalo Assigned To => Zeljan Rikalo
2011-10-22 13:13 Zeljan Rikalo Fixed in Revision => 33018
2011-10-22 13:13 Zeljan Rikalo Status assigned => resolved
2011-10-22 13:13 Zeljan Rikalo Resolution open => fixed
2011-10-22 13:13 Zeljan Rikalo Note Added: 0053272
2011-10-22 19:22 silvioprog Note Added: 0053288
2011-10-22 19:45 Zeljan Rikalo Note Added: 0053289
2011-10-23 18:15 silvioprog Note Added: 0053332
2011-10-28 23:49 silvioprog Status resolved => closed
2020-10-20 21:03 Juha Manninen Relationship added related to 0037942