View Issue Details

IDProjectCategoryView StatusLast Update
0020502LazarusLCLpublic2011-10-18 07:52
Reportereclipticon Assigned ToVincent Snijders  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionduplicate 
Product Version0.9.30 
Summary0020502: Width of TFileNameEdit, TDirectoryEdit
DescriptionThe width property reported by TFileNameEdit, TDirectoryEdit, etc. only refers to the string edit field but does not take the (optional) icon into account. This makes correct alignment of visual components very hard.

Is there any particular reason to handle .Width like this?
TagsNo tags attached.
Fixed in Revision
LazTarget-
WidgetsetWin32/Win64
Attached Files

Relationships

duplicate of 0012155 closedBart Broersma TEditButton aligns incorrect (glyph is not taken into account) 

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2011-10-17 22:46 eclipticon New Issue
2011-10-17 22:46 eclipticon Widgetset => Win32/Win64
2011-10-17 23:59 Juha Manninen Relationship added duplicate of 0012155
2011-10-18 07:51 Vincent Snijders LazTarget => -
2011-10-18 07:51 Vincent Snijders Status new => resolved
2011-10-18 07:51 Vincent Snijders Resolution open => duplicate
2011-10-18 07:51 Vincent Snijders Assigned To => Vincent Snijders