View Issue Details

IDProjectCategoryView StatusLast Update
0020508LazarusLCLpublic2011-10-21 11:20
ReporterRobson Dantas Assigned ToVincent Snijders  
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version0.9.31 (SVN) 
Target Version1.0.0 
Summary0020508: Component TImageList does not store images
DescriptionThe Component TImageList does not store images.

It adds the images, but when leaving the editor (ImageList) and returning, it is noticed that the images were not stored in the component.
Images that were previously stored no longer appear.
Additional Information*.gif
*.jpg
*.bmp

The component TImageList does not store images.
Example not included (not attached).

FPC 2.7.1 r19477
Lazarus 0.9.31 r32949M FPC 2.7.1 i386-linux-gtk 2
TagsNo tags attached.
Fixed in Revision
LazTarget1.0
WidgetsetGTK 2
Attached Files

Activities

Vojtech Cihak

2011-10-18 15:24

reporter   ~0053131

I cannot confirm on Linux+Qt, r 32962. I have not enough small *.jpg, *.gif and *.bmp files, I tested with small *.png files and with one big splitted *.jpeg.

Bart Broersma

2011-10-19 14:01

developer   ~0053156

ATM you should not use Lazarus with fpc 2.7.x AFAIK

Robson Dantas

2011-10-19 17:54

reporter   ~0053170

why?

Juha Manninen

2011-10-20 00:12

developer   ~0053181

Works well here on Linux + GTK2.

Flávio Etrusco

2011-10-20 06:47

developer   ~0053184

Robson, if you don't have any special reason for using 2.7.1, then don't use it (this holds true for any development branch/unstable software).

Robson Dantas

2011-10-20 14:36

reporter   ~0053203

@Flávio Etrusco

I do not use in production. Use to test and report errors for correction

Bart Broersma

2011-10-20 16:17

developer   ~0053205

The behaviour of fpc 2.7.x can change in any direction.
It makes no sense to change Lazarus/LCL code, only because it does not work correctly with the currrent state of the fpc trunk.
Lazarus is only guaranteed to work with latest stable compiler.

Vincent Snijders

2011-10-21 09:37

manager   ~0053228

Please, attach sample images, so we can try to reproduce this issue.

Robson Dantas

2011-10-21 10:58

reporter   ~0053231

I upgraded to the new version of Lazarus and the problem was corrected.

New:
Lazarus 0.9.31 r33000M FPC 2.7.1 i386-linux-gtk 2

Old:
Lazarus 0.9.31 r32949M FPC 2.7.1 i386-linux-gtk 2

When I was looking for images, I realized they were working. Any update messed with the component.

Issue History

Date Modified Username Field Change
2011-10-18 14:04 Robson Dantas New Issue
2011-10-18 14:04 Robson Dantas Widgetset => GTK 2
2011-10-18 15:24 Vojtech Cihak Note Added: 0053131
2011-10-19 14:01 Bart Broersma Note Added: 0053156
2011-10-19 17:54 Robson Dantas Note Added: 0053170
2011-10-20 00:12 Juha Manninen Note Added: 0053181
2011-10-20 06:47 Flávio Etrusco Note Added: 0053184
2011-10-20 14:36 Robson Dantas Note Added: 0053203
2011-10-20 16:17 Bart Broersma Note Added: 0053205
2011-10-21 09:37 Vincent Snijders LazTarget => -
2011-10-21 09:37 Vincent Snijders Status new => feedback
2011-10-21 09:37 Vincent Snijders LazTarget - => 1.0
2011-10-21 09:37 Vincent Snijders Note Added: 0053228
2011-10-21 09:37 Vincent Snijders Target Version => 1.0.0
2011-10-21 10:58 Robson Dantas Note Added: 0053231
2011-10-21 11:20 Vincent Snijders Status feedback => resolved
2011-10-21 11:20 Vincent Snijders Resolution open => fixed
2011-10-21 11:20 Vincent Snijders Assigned To => Vincent Snijders