View Issue Details

IDProjectCategoryView StatusLast Update
0020555LazarusDebuggerpublic2011-10-26 05:34
ReporterAnnaAssigned ToMartin Friebe 
PrioritynormalSeverityblockReproducibilityalways
Status closedResolutionfixed 
Product Version0.9.31 (SVN)Product Build 
Target VersionFixed in Version0.9.31 (SVN) 
Summary0020555: Breakpoints don't work. App doesn't stop on breakpoint.
Descriptionvideo bug-demonstration: http://www.youtube.com/watch?v=V022tOCXWCc
Additional InformationLazarus snapshot: Lazarus-0.9.31-33036-fpc-2.5.1-20111023-win32z.exe
OS: Windows XP SP3 Pro 32-bit Russian
TagsNo tags attached.
Fixed in Revision33081
LazTarget0.99.0
Widgetset
Attached Files

Activities

Juha Manninen

2011-10-24 18:52

developer   ~0053375

Anna, you don't have debug info in your app.
Blue dots at left side of source editor indicate there is debug info.
Please check it.

Anna

2011-10-24 20:01

reporter   ~0053379

Last edited: 2011-10-24 20:57

Switched off debug info is acheaved by -g- swith, isn't it?
Here my Build options:
http://img692.imageshack.us/img692/5752/51414821n.png
As you see debug is switched on.

Martin Friebe

2011-10-24 21:25

manager   ~0053384

The picture shows debug info for the LCL, and the IDE.
That does not say, if your project has it too.

Please follow the steps on
http://wiki.lazarus.freepascal.org/Debugger_Setup (especially "Project Options")

If you have debug info enabled, and it still fails, then please attach the following info:

After you compile ("project" > "Build"), right click the "message window", and select "Copy all and hidden messages". Attach the copied msgs here.

Before running your app, open the "Debug output" window, and after running it copy the content and attach. See http://wiki.lazarus.freepascal.org/GDB_Debugger_Tips#Create_a_new_Report

Anna

2011-10-25 03:29

reporter   ~0053392

Last edited: 2011-10-25 04:12

2 Martin Friebe
Yup, in project options [Project > Project Options ...> Compiler Options > Linking > Generate Debug Info For GDB (Slower / Increases exe-size)] for some reasons debug info is off.
So now I must turn on this checkbox for each project. In old Lazarus releases this checkbox was switched on automatically.
Tell me, how to get old lazarus behaviour back?

Wait for minute, I just test Lazarus-0.9.31-32070-fpc-2.4.4-20110828-win32
.exe and it also has switched off 'Generate Debug Info For GDB' ( http://img802.imageshack.us/img802/4774/30010882.png ; http://www.youtube.com/watch?v=7JTRX4ZbZ9Q) but i see blue dots. So it's still a bug .

Martin Friebe

2011-10-25 11:51

manager   ~0053402

Fixed in 33081. Please close if ok.

Indeed the default had changed, as it was previously implied through "line-info" (which does add debug info).

Martin Friebe

2011-10-25 11:55

manager   ~0053403

The old settings page was inconsistent:

It would display "Generate dbg info" = "off", while it was infact on, because "generate line info" does automatically include dbg-info

Anna

2011-10-26 05:34

reporter   ~0053442

Generate Debug Info For GDB (Slower / Increases exe-size) always switched on, as supposed to be. Thank you very much, (^_^)

Issue History

Date Modified Username Field Change
2011-10-24 17:24 Anna New Issue
2011-10-24 17:24 Anna Status new => assigned
2011-10-24 17:24 Anna Assigned To => Marc Weustink
2011-10-24 18:52 Juha Manninen LazTarget => -
2011-10-24 18:52 Juha Manninen Note Added: 0053375
2011-10-24 18:52 Juha Manninen Status assigned => feedback
2011-10-24 20:01 Anna Note Added: 0053379
2011-10-24 20:57 Anna Note Edited: 0053379
2011-10-24 21:19 Martin Friebe Status feedback => assigned
2011-10-24 21:19 Martin Friebe Assigned To Marc Weustink => Martin Friebe
2011-10-24 21:25 Martin Friebe Note Added: 0053384
2011-10-24 21:25 Martin Friebe Status assigned => feedback
2011-10-25 03:29 Anna Note Added: 0053392
2011-10-25 03:30 Anna Note Edited: 0053392
2011-10-25 03:31 Anna Note Edited: 0053392
2011-10-25 03:31 Anna Note Edited: 0053392
2011-10-25 03:48 Anna Note Edited: 0053392
2011-10-25 03:50 Anna Note Edited: 0053392
2011-10-25 03:52 Anna Note Edited: 0053392
2011-10-25 04:12 Anna Note Edited: 0053392
2011-10-25 11:51 Martin Friebe Fixed in Revision => 33081
2011-10-25 11:51 Martin Friebe LazTarget - => 0.99.0
2011-10-25 11:51 Martin Friebe Status feedback => resolved
2011-10-25 11:51 Martin Friebe Fixed in Version => 0.9.31 (SVN)
2011-10-25 11:51 Martin Friebe Resolution open => fixed
2011-10-25 11:51 Martin Friebe Note Added: 0053402
2011-10-25 11:52 Martin Friebe Target Version => 0.99.0
2011-10-25 11:55 Martin Friebe Note Added: 0053403
2011-10-26 05:34 Anna Status resolved => closed
2011-10-26 05:34 Anna Note Added: 0053442