View Issue Details

IDProjectCategoryView StatusLast Update
0020597LazarusIDEpublic2011-12-06 21:06
ReporterbillyraybonesAssigned ToMaxim Ganetsky 
PrioritynormalSeverityminorReproducibilityN/A
Status resolvedResolutionfixed 
Product Version0.9.31 (SVN)Product Build 
Target VersionFixed in Version0.9.31 (SVN) 
Summary0020597: IDE German language file
DescriptionGot the lazide.po file 2 hours ago, made some translations, zipped it and posted it again.
TagsNo tags attached.
Fixed in Revision34006
LazTarget0.99.0
Widgetset
Attached Files

Activities

2011-10-30 23:33

 

lazaruside.de.zip (128,587 bytes)

Maxim Ganetsky

2011-10-31 20:47

developer   ~0053695

Did you contact Swen Heinig? What's his opinion?

Swen Heinig

2011-11-01 16:10

developer   ~0053720

some comments from my side

- "reverse fold-order in popup": translation is to long, there is not enough space in the dialog
- "Ctrl-middle-click on tab closes all others": translation is to long...
- "Use tab history when closing tabs": translation is to long...
- "&Address Breakpoint ...": the translation differs from official usage (e.g. Embarcadero)
- "Invalid component owner": bad german
- "Extend far left": translation is to long...
- "Extend some left": translation is to long...
- "Collapse All (/)": existing translation was removed
- "Create &Data/Watch Breakpoint ...": existing translation was removed
and some more ...

Most of the translations are ok. But we will have to do double work if we use the attached file. How can we prevent this?

Martin Friebe

2011-11-01 16:22

manager   ~0053721

Couple more things (may have already existed, don't know)

#: lazarusidestrconsts.dlfmousesimplediff
msgid "This page does not represent your current settings. See advanced page. Use this page to reset any advanced changes"
msgstr "Diese Seite enthält nicht die derzeitigen Einstellungen. Sehen Sie in der erweiterten Seite nach und setzen Sie hier die vorgeschrittenen Änderungen zurück"

2 different translations for "advanced" makes no sense. as the 2nd "reset advanced" refers to what can be viewed according to the 1st "see advanced"

"und" should be "oder", the 2 sentences present alternatives.



#: lazarusidestrconsts.dlfmousesimplewarning
msgid "You have unsaved changes. Using this page will undo changes made on the advanced page"
msgstr "Änderungen wurden nicht gespeichert. Auf dieser Seite können Änderungen auf der fortgeschrittenen Seite zurückgenommen werden"

Translation makes no sense at all

Swen Heinig

2011-11-01 16:32

developer   ~0053722

#: lazarusidestrconsts.dlfmousesimplewarning

This string should be removed from the po files, because the corresponding page in the Lazarus options does no longer exist.

Maxim Ganetsky

2011-11-03 22:04

developer   ~0053789

Last edited: 2011-11-03 22:10

@Swen.

>#: lazarusidestrconsts.dlfmousesimplewarning
>
>This string should be removed from the po files, because the corresponding page in the Lazarus options does no longer exist.

You are wrong, it is used and the page is not removed.

>But we will have to do double work if we use the attached file. How can we prevent this?

The simplest way is for you to take this file, make necessary corrections and submit it here or by mail.

2011-11-04 00:25

 

lazaruside.de-005.zip (128,690 bytes)

billyraybones

2011-11-04 00:25

reporter   ~0053791

@Swen:
-----------------------------------
Shortened some of the translations:
-----------------------------------
1) Reverse fold-order in Popup --> Umgek. Faltungsfolge im Popup
2) Ctrl-middle-click on tab closes all others --> Strg-Mittelklick auf Tab schließt alle anderen
3) Use tab history when closing tabs --> Tabs laut Historie schließen
4) Extend far left --> Erweitern (weit links)
5) Extend some left --> Erweitern (etwas links)
--------------------------
&Address Breakpoint ...: Don't have Embarcadero
-----------------------------------------------
"Invalid component owner": bad german

invalid = ungültig, unbekannt, nicht existent, nicht zugewiesen, ... ???
owner = Besitzer, Eigentümer, Eigner, ... ???
-----------------------------------------------
existing translation was removed:

I did NOT remove any translations! They were not in the lazide.de.po file I got via SVN on 2011-10-30.
But I translated them NOW (only 16 left untranslated).
------------------------------------------------------

@Martin Friebe:

1)
#: lazarusidestrconsts.dlfmousesimplediff
This page does not represent your current settings. See advanced page. Use this page to reset any advanced changes -->
    Diese Seite enthält nicht Ihre derzeitigen Einstellungen. Sehen Sie in der erweiterten Seite nach oder nehmen Sie hier die vorgenommenen Änderungen zurück

2)
#: lazarusidestrconsts.dlfmousesimplewarning-->removed-->put in again as Maxim was faster than my corrections.
3) Translation makes no sense at all. Yes, maybe.
-------------------------------------------------
@ Swen & Martin:

I don't understand all the features of Lazarus. I only translated some of the missing strings in the lazide.de.po file. And I think, getting 190 good translations of 200 missing (and maybe 10 bad ones) is always better than no translation at all.
I guess Maxim got it right: Most translations will do. If something is wrong we'll correct them afterwards, one by one.

Thank you, guys!
---

Added new version of lazide.po file (lazaruside.de-005.zip)

BRB

Maxim Ganetsky

2011-11-04 18:20

developer   ~0053803

@billyraybones: in order not to lose any translations you should always use latest SVN trunk revision.

billyraybones

2011-11-04 18:53

reporter   ~0053804

Yes, I should. Sorry!
When I translated it and posted it it was only 2 hours old. But it always takes a few days to wait for the responses and so on...
 
It would be easier if I had only 4 or 5 new strings to translate. But as long as we aren't up-to-date with the translations I always have to compare the whole file. And I hopefully am not skipping any new made changes.

I thought it would be an easy choice:
-now, many missing string, some outdated and some wrong
-then, almost complete file (with some wrong)

It seems, I have to deliver the whole translation sentence by sentence.

Anyway, thank you for your help, Maxim.

BRB

2011-11-04 19:21

 

lazaruside.de-006.zip (126,530 bytes)

billyraybones

2011-11-04 19:21

reporter   ~0053806

OK. Here's the old file from SVN
Received: 2011-11-04, 19:00
Only 5 strings translated: e.g.: Select groups...
Zipped: 2011-11-04, 19:14
Transmitted (lazide.de-006.zip): 2011-11-04, 19:21

BRB

Maxim Ganetsky

2011-12-06 21:06

developer   ~0054759

Last edited: 2011-12-06 21:07

I committed updated translation by Swen Heinig. It incorporates your changes.

Thanks.

Please close if ok.

Issue History

Date Modified Username Field Change
2011-10-30 23:33 billyraybones New Issue
2011-10-30 23:33 billyraybones File Added: lazaruside.de.zip
2011-10-30 23:33 billyraybones Widgetset => Win32/Win64
2011-10-31 20:42 Maxim Ganetsky LazTarget => -
2011-10-31 20:42 Maxim Ganetsky Status new => assigned
2011-10-31 20:47 Maxim Ganetsky LazTarget - => 0.99.0
2011-10-31 20:47 Maxim Ganetsky Note Added: 0053695
2011-10-31 20:47 Maxim Ganetsky Assigned To => Maxim Ganetsky
2011-10-31 20:47 Maxim Ganetsky Status assigned => feedback
2011-10-31 20:47 Maxim Ganetsky Target Version => 0.99.0
2011-11-01 16:10 Swen Heinig Note Added: 0053720
2011-11-01 16:22 Martin Friebe Note Added: 0053721
2011-11-01 16:32 Swen Heinig Note Added: 0053722
2011-11-03 22:04 Maxim Ganetsky Note Added: 0053789
2011-11-03 22:06 Maxim Ganetsky Note Edited: 0053789
2011-11-03 22:10 Maxim Ganetsky Note Edited: 0053789
2011-11-04 00:25 billyraybones File Added: lazaruside.de-005.zip
2011-11-04 00:25 billyraybones Note Added: 0053791
2011-11-04 18:20 Maxim Ganetsky Note Added: 0053803
2011-11-04 18:53 billyraybones Note Added: 0053804
2011-11-04 19:21 billyraybones File Added: lazaruside.de-006.zip
2011-11-04 19:21 billyraybones Note Added: 0053806
2011-12-06 21:06 Maxim Ganetsky Fixed in Revision => 34006
2011-12-06 21:06 Maxim Ganetsky Widgetset Win32/Win64 =>
2011-12-06 21:06 Maxim Ganetsky Status feedback => resolved
2011-12-06 21:06 Maxim Ganetsky Fixed in Version => 0.9.31 (SVN)
2011-12-06 21:06 Maxim Ganetsky Resolution open => fixed
2011-12-06 21:06 Maxim Ganetsky Note Added: 0054759
2011-12-06 21:07 Maxim Ganetsky Note Edited: 0054759