View Issue Details

IDProjectCategoryView StatusLast Update
0020602LazarusIDEpublic2020-01-12 19:33
ReporterJohn Shand Assigned ToZeljan Rikalo  
PrioritynormalSeverityblockReproducibilityalways
Status resolvedResolutionfixed 
Product Version0.9.31 (SVN) 
Summary0020602: Form property 'visible' issue
Descriptioni changed the property to being invisible to all forms except login. however when i run the project or reopen the project i find that the visible property has been reset to being visible again on all forms.
TagsNo tags attached.
Fixed in Revision35581
LazTarget-
WidgetsetGTK, GTK 2, Win32/Win64, WinCE, Carbon, Cocoa, QT
Attached Files

Relationships

related to 0020595 closedJuha Manninen Discrepancy when calling show (bringtofront) of designed form 
related to 0020592 resolvedMattias Gaertner Modal form issue 

Activities

Mattias Gaertner

2011-10-31 21:07

manager   ~0053698

I tried:
I open a form, set Visible to false, close form, IDE asks to save, I say yes, I open the form, Visible is false.

Any more hints how to reproduce this?

Zeljan Rikalo

2011-10-31 22:00

developer   ~0053699

@Mattias, maybe yes. Try to bring that form into front via Window->YourFormName.
Something is definitelly wrong there.
1.Form is resized (I've already opened an issue about it)
  http://bugs.freepascal.org/view.php?id=20595
2.Sometimes using Window->yourFormName sets Visible to true of designed form, but I think it depends on current selected item in OI.

When you use F12 to bring form to front or clicking on it then no problems.

Zeljan Rikalo

2011-11-01 11:08

developer   ~0053707

just to trigger Mattias

Juha Manninen

2011-11-11 11:57

developer   ~0054007

jshand2010, could you try with a clean Lazarus configuration.
See the related issue for details.

Juha Manninen

2011-11-20 10:38

developer   ~0054289

Most likely a configuration / installation problem. Resolving now.

Stephano

2011-11-25 10:17

developer   ~0054444

The bug that sets TForm.visible to true is still there.
Zeljan confirmed it too.

Juha Manninen

2011-11-25 11:57

developer   ~0054447

Ok, I reopen the issue and remove the assignment.

Zeljan Rikalo

2012-02-24 15:18

developer   ~0057067

Changed to IDE, affected all ws.

Zeljan Rikalo

2012-02-24 15:27

developer   ~0057068

Please test and close if ok.

Issue History

Date Modified Username Field Change
2011-10-31 20:51 John Shand New Issue
2011-10-31 20:51 John Shand Widgetset => GTK 2
2011-10-31 21:07 Mattias Gaertner Note Added: 0053698
2011-10-31 21:25 Maxim Ganetsky LazTarget => -
2011-10-31 21:25 Maxim Ganetsky Status new => feedback
2011-10-31 22:00 Zeljan Rikalo Note Added: 0053699
2011-11-01 11:08 Zeljan Rikalo Note Added: 0053707
2011-11-01 11:08 Zeljan Rikalo Status feedback => acknowledged
2011-11-05 08:16 Juha Manninen Relationship added related to 0020595
2011-11-11 11:55 Juha Manninen Status acknowledged => assigned
2011-11-11 11:55 Juha Manninen Assigned To => Juha Manninen
2011-11-11 11:57 Juha Manninen Note Added: 0054007
2011-11-11 11:57 Juha Manninen Status assigned => feedback
2011-11-20 10:38 Juha Manninen Status feedback => resolved
2011-11-20 10:38 Juha Manninen Resolution open => unable to reproduce
2011-11-20 10:38 Juha Manninen Note Added: 0054289
2011-11-25 10:17 Stephano Note Added: 0054444
2011-11-25 11:57 Juha Manninen Assigned To Juha Manninen =>
2011-11-25 11:57 Juha Manninen Status resolved => assigned
2011-11-25 11:57 Juha Manninen Resolution unable to reproduce => reopened
2011-11-25 11:57 Juha Manninen Note Added: 0054447
2011-11-25 11:58 Juha Manninen Status assigned => new
2012-02-04 14:36 Zeljan Rikalo Relationship added related to 0020592
2012-02-24 15:18 Zeljan Rikalo Widgetset GTK 2 => GTK, GTK 2, Win32/Win64, WinCE, Carbon, Cocoa, QT
2012-02-24 15:18 Zeljan Rikalo Note Added: 0057067
2012-02-24 15:18 Zeljan Rikalo Category Other => IDE
2012-02-24 15:27 Zeljan Rikalo Fixed in Revision => 35581
2012-02-24 15:27 Zeljan Rikalo Status new => resolved
2012-02-24 15:27 Zeljan Rikalo Resolution reopened => fixed
2012-02-24 15:27 Zeljan Rikalo Assigned To => Zeljan Rikalo
2012-02-24 15:27 Zeljan Rikalo Note Added: 0057068