View Issue Details

IDProjectCategoryView StatusLast Update
0020611LazarusLCLpublic2011-11-18 12:45
ReporterVojtech CihakAssigned ToFelipe Monteiro de Carvalho 
PrioritynormalSeveritytweakReproducibilityalways
Status closedResolutionfixed 
Product Version0.9.31 (SVN)Product Build 
Target VersionFixed in Version0.9.31 (SVN) 
Summary0020611: Change declaration of GetRGBValues
DescriptionDeclaration:
procedure GetRGBValues(RGB : DWORD; var R, G, B: Byte); inline;
procedure GetRGBIntValues(RGB : DWORD; var R, G, B: integer); inline;

"var" should be changed to "out" to avoid compiler messages that
Local variable R, G and B does not seem to be initialized.

Those variables are just output.

Lazarus 0.9.31 r33105M FPC 2.5.1 x86_64-linux-qt
TagsNo tags attached.
Fixed in Revision33608
LazTarget-
WidgetsetGTK, GTK 2, Win32/Win64, WinCE, Carbon, Cocoa, QT
Attached Files

Activities

Zeljan Rikalo

2011-11-02 18:53

developer   ~0053758

@Felipe, I've assigned this to you ,since you're mostly in drawing last weeks :)

Felipe Monteiro de Carvalho

2011-11-03 10:41

developer   ~0053762

Do these routines exist in Delphi? In a short search I couldnt find.

Felipe Monteiro de Carvalho

2011-11-16 08:07

developer   ~0054113

These routines are in LCLIntf in the winapi part and are inlined. I couldn't find them in the windows unit in a quick search.

Zeljan Rikalo

2011-11-16 10:00

developer   ~0054116

@Felipe, issue is not about naming clash, but about adding out instead var params, so it'll shutup compiler.

Felipe Monteiro de Carvalho

2011-11-18 11:32

developer   ~0054189

Ah, it was only a mental note of what I researched about this. I just wanted to research all possibilities of backwards compatibility break.

Vojtech Cihak

2011-11-18 12:45

reporter   ~0054193

Tested with 33610. Thanks.

Issue History

Date Modified Username Field Change
2011-11-02 02:09 Vojtech Cihak New Issue
2011-11-02 02:09 Vojtech Cihak Widgetset => GTK, GTK 2, Win32/Win64, WinCE, Carbon, Cocoa, QT
2011-11-02 18:53 Zeljan Rikalo LazTarget => -
2011-11-02 18:53 Zeljan Rikalo Note Added: 0053758
2011-11-02 18:53 Zeljan Rikalo Assigned To => Felipe Monteiro de Carvalho
2011-11-02 18:53 Zeljan Rikalo Status new => assigned
2011-11-03 10:41 Felipe Monteiro de Carvalho Note Added: 0053762
2011-11-16 08:07 Felipe Monteiro de Carvalho Note Added: 0054113
2011-11-16 10:00 Zeljan Rikalo Note Added: 0054116
2011-11-18 11:32 Felipe Monteiro de Carvalho Fixed in Revision => 33608
2011-11-18 11:32 Felipe Monteiro de Carvalho Status assigned => resolved
2011-11-18 11:32 Felipe Monteiro de Carvalho Fixed in Version => 0.9.31 (SVN)
2011-11-18 11:32 Felipe Monteiro de Carvalho Resolution open => fixed
2011-11-18 11:32 Felipe Monteiro de Carvalho Note Added: 0054189
2011-11-18 12:45 Vojtech Cihak Status resolved => closed
2011-11-18 12:45 Vojtech Cihak Note Added: 0054193