View Issue Details

IDProjectCategoryView StatusLast Update
0020670LazarusLCLpublic2012-03-12 16:00
ReportercobinesAssigned ToPaul Ishenin 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformWin32OSWindows XPOS VersionSP3
Product Version0.9.31 (SVN)Product Build33481 
Target VersionFixed in Version0.9.31 (SVN) 
Summary0020670: Cannot restore/show hidden minimized form [regression]
DescriptionAfter minimizing a form and hiding it (so that taskbar button is not shown) it is not possible to show it again.

I hide this way:

  Form2.WindowState := wsMinimized;
  Form2.Hide;

and restore with:

  Form2.ShowOnTop;

If the form is only minimized or only hidden it works.

This used to work but from 33145 it stopped working.
Steps To Reproduce1. Run attached example.
2. Press Hide and WindowState := wsMinimized (in any order). Form2 disappears.
3. Press ShowOnTop - Form2 is not shown.
TagsNo tags attached.
Fixed in Revision34004, 35169
LazTarget0.99.0
WidgetsetWin32/Win64
Attached Files

Relationships

related to 0019886 closedJuha Manninen Form with only width constraint changes height to zero after minimize/restore 
related to 0018514 resolvedOndrej Pokorny show on minimized form 

Activities

2011-11-12 00:29

 

restore_from_tray_window_hidden.zip (1,913 bytes)

cobines

2011-11-12 00:39

reporter   ~0054024

Happens on Windows (win32) and Linux (qt4, gtk2) so doesn't seem to be widgetset dependent.

Zeljan Rikalo

2011-11-12 08:00

developer   ~0054025

Yes, ugly behaviour

Juha Manninen

2011-11-16 10:26

developer   ~0054118

r33145 solved the related issue but caused this one.

Zeljan Rikalo

2011-12-06 19:18

developer   ~0054751

Please test and close if ok.

cobines

2011-12-07 13:58

reporter   ~0054778

I tested on Linux/Gtk2 and Linux/Qt4 and it works, but on Windows XP/win32 it still doesn't work.

Zeljan Rikalo

2011-12-07 14:26

developer   ~0054781

Changed to win32 only bug.

Zeljan Rikalo

2011-12-07 14:26

developer   ~0054782

Let someone else fix win32

Zeljan Rikalo

2012-02-04 12:24

developer   ~0056350

@Paul please look what to do with this one. Looks like regression, but win32 only.

Paul Ishenin

2012-02-06 07:08

manager   ~0056557

Please test and close if ok.

Issue History

Date Modified Username Field Change
2011-11-12 00:29 cobines New Issue
2011-11-12 00:29 cobines File Added: restore_from_tray_window_hidden.zip
2011-11-12 00:39 cobines Note Added: 0054024
2011-11-12 08:00 Zeljan Rikalo LazTarget => -
2011-11-12 08:00 Zeljan Rikalo Note Added: 0054025
2011-11-12 08:00 Zeljan Rikalo Status new => confirmed
2011-11-12 08:01 Zeljan Rikalo LazTarget - => 1.0
2011-11-16 10:23 Juha Manninen Relationship added related to 0019886
2011-11-16 10:26 Juha Manninen Note Added: 0054118
2011-11-18 17:33 Juha Manninen Relationship added related to 0018514
2011-12-06 19:16 Zeljan Rikalo Status confirmed => assigned
2011-12-06 19:16 Zeljan Rikalo Assigned To => Zeljan Rikalo
2011-12-06 19:18 Zeljan Rikalo Fixed in Revision => 34004
2011-12-06 19:18 Zeljan Rikalo Status assigned => resolved
2011-12-06 19:18 Zeljan Rikalo Resolution open => fixed
2011-12-06 19:18 Zeljan Rikalo Note Added: 0054751
2011-12-07 13:58 cobines Status resolved => assigned
2011-12-07 13:58 cobines Resolution fixed => reopened
2011-12-07 13:58 cobines Note Added: 0054778
2011-12-07 14:26 Zeljan Rikalo Widgetset => Win32/Win64
2011-12-07 14:26 Zeljan Rikalo Note Added: 0054781
2011-12-07 14:26 Zeljan Rikalo Note Added: 0054782
2011-12-07 14:26 Zeljan Rikalo Assigned To Zeljan Rikalo =>
2011-12-07 22:39 Juha Manninen Status assigned => new
2011-12-18 10:34 Vincent Snijders LazTarget 1.0 => 0.99.0
2011-12-18 10:34 Vincent Snijders Status new => acknowledged
2011-12-18 10:34 Vincent Snijders Target Version => 0.99.0
2012-02-04 12:24 Zeljan Rikalo Note Added: 0056350
2012-02-04 12:24 Zeljan Rikalo Status acknowledged => assigned
2012-02-04 12:29 Zeljan Rikalo Assigned To => Paul Ishenin
2012-02-06 07:08 Paul Ishenin Fixed in Revision 34004 => 34004, 35169
2012-02-06 07:08 Paul Ishenin Status assigned => resolved
2012-02-06 07:08 Paul Ishenin Fixed in Version => 0.9.31 (SVN)
2012-02-06 07:08 Paul Ishenin Resolution reopened => fixed
2012-02-06 07:08 Paul Ishenin Note Added: 0056557
2012-03-12 16:00 cobines Status resolved => closed