View Issue Details

IDProjectCategoryView StatusLast Update
0020674LazarusLCLpublic2011-11-13 18:07
Reportersilvioprog Assigned ToZeljan Rikalo  
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Summary0020674: AutoSize does not work in SpeedButton
DescriptionHi,

Steps to reproduce the error:

1. Put a TButton in a form;
2. Set width of button to 300;
3. Set Caption property to "test";
4. Set AutoSize property to True;

The button will be adjusted automatically.

Now:

1. Put a TSpeedButton in a form;
2. Set width of button to 300;
3. Set Caption property to "test";
4. Set AutoSize property to True;

The speedbutton remain with width in 23.

My Lazarus/FPC:

Lazarus 0.9.30.2RC2 r33063 FPC 2.4.4 i386-win32-win32/win64 (Windows 7)

Lazarus 0.9.30.2RC2-0 r33063 FPC 2.4.4 i386-linux-gtk 2 (Mint 11)

Lazarus 0.9.31 r33501 FPC 2.4.4 i386-linux-gtk 2 (openSUSE 11.4)

Lazarus 0.9.31 r33501 FPC 2.4.4 i386-linux-qt (openSUSE 11.4)
TagsNo tags attached.
Fixed in Revision
LazTarget-
WidgetsetGTK 2, Win32/Win64, QT
Attached Files

Relationships

duplicate of 0013961 closedBart Broersma Missing published TSpeedButton.Autosize property 

Activities

Zeljan Rikalo

2011-11-13 17:54

developer   ~0054054

That's already reported issue.

silvioprog

2011-11-13 18:03

reporter   ~0054057

Which the link?

Zeljan Rikalo

2011-11-13 18:04

developer   ~0054058

It's duplicated issue of
http://bugs.freepascal.org/view.php?id=13961

silvioprog

2011-11-13 18:07

reporter   ~0054059

Thanks! :)

Issue History

Date Modified Username Field Change
2011-11-13 17:20 silvioprog New Issue
2011-11-13 17:20 silvioprog Widgetset => GTK 2, Win32/Win64, QT
2011-11-13 17:54 Zeljan Rikalo Note Added: 0054054
2011-11-13 18:03 silvioprog Note Added: 0054057
2011-11-13 18:04 Zeljan Rikalo Relationship added duplicate of 0013961
2011-11-13 18:04 Zeljan Rikalo LazTarget => -
2011-11-13 18:04 Zeljan Rikalo Status new => resolved
2011-11-13 18:04 Zeljan Rikalo Resolution open => fixed
2011-11-13 18:04 Zeljan Rikalo Assigned To => Zeljan Rikalo
2011-11-13 18:04 Zeljan Rikalo Note Added: 0054058
2011-11-13 18:07 silvioprog Status resolved => closed
2011-11-13 18:07 silvioprog Note Added: 0054059