View Issue Details

IDProjectCategoryView StatusLast Update
0020686LazarusOtherpublic2013-09-03 12:07
ReporterRobson DantasAssigned ToJuha Manninen 
PrioritynormalSeverityblockReproducibilityalways
Status resolvedResolutionfixed 
Product Version0.9.31 (SVN)Product Build 
Target VersionFixed in Version0.9.31 (SVN) 
Summary0020686: lazarus/tools/snapshots does not compile
DescriptionFailed to put a unit in the uses: fileutil

After adding the unit is possible to build. :)
Additional Informationunit SnapshotsUptodate;

{$mode objfpc}{$H+}

interface

uses
  Classes, SysUtils, fileutil, fpcunit, testregistry, ftplister;

// Add "fileutil" in uses up
TagsNo tags attached.
Fixed in Revision36038
LazTarget1.4
WidgetsetGTK 2
Attached Files

Activities

Juha Manninen

2011-12-21 10:59

developer   ~0055199

I fixed the compilation in r34343.
How is this tool used? I got lots of assertion failures when running it.

Vincent Snijders

2011-12-21 18:38

manager   ~0055207

I guess it won't work anymore, because the location of snapshots have changed.

Robson Dantas

2011-12-21 18:55

reporter   ~0055208

Still the same error. adding fileutil in uses, works well.

2011-12-21 18:59

 

screenshots.png (126,785 bytes)
screenshots.png (126,785 bytes)

Robson Dantas

2011-12-21 19:06

reporter   ~0055209

ok, Failures: 48 :(

You can close this thread.

Juha Manninen

2011-12-21 20:02

developer   ~0055211

> I guess it won't work anymore, because the location of snapshots have changed.

Vincent, how to fix it? It should be either fixed or removed.

Vincent Snijders

2011-12-21 23:09

manager   ~0055213

Last edited: 2011-12-21 23:11

I vote for remove, because I won't maintain it (no time, other priorities).

Fixing would require updating some configs, I guess.

Juha Manninen

2011-12-27 00:43

developer   ~0055304

Updating some configs doesn't sound very difficult.
Now the problem is I don't know anything about this snapshots tool. I have never seen it working.
Would it still be useful?
If "yes" then could someone create a patch or explain the problem.
If "no" then let's remove it.

Vincent Snijders

2011-12-27 10:33

manager   ~0055312

It is useful if you want to see in one glance if all snapshots are less than 24 hours old.

Issue History

Date Modified Username Field Change
2011-11-15 12:45 Robson Dantas New Issue
2011-11-15 12:45 Robson Dantas Widgetset => GTK 2
2011-12-21 10:57 Juha Manninen Status new => assigned
2011-12-21 10:57 Juha Manninen Assigned To => Juha Manninen
2011-12-21 10:59 Juha Manninen LazTarget => -
2011-12-21 10:59 Juha Manninen Note Added: 0055199
2011-12-21 10:59 Juha Manninen Status assigned => feedback
2011-12-21 18:38 Vincent Snijders Note Added: 0055207
2011-12-21 18:55 Robson Dantas Note Added: 0055208
2011-12-21 18:59 Robson Dantas File Added: screenshots.png
2011-12-21 19:06 Robson Dantas Note Added: 0055209
2011-12-21 20:02 Juha Manninen Note Added: 0055211
2011-12-21 23:09 Vincent Snijders Note Added: 0055213
2011-12-21 23:11 Vincent Snijders Note Edited: 0055213
2011-12-27 00:43 Juha Manninen Note Added: 0055304
2011-12-27 10:33 Vincent Snijders Note Added: 0055312
2012-02-04 11:34 Zeljan Rikalo LazTarget - => post 1.2
2012-03-15 19:31 Vincent Snijders Fixed in Revision => 36038
2012-03-15 19:31 Vincent Snijders Status feedback => resolved
2012-03-15 19:31 Vincent Snijders Fixed in Version => 0.9.31 (SVN)
2012-03-15 19:31 Vincent Snijders Resolution open => fixed
2013-09-03 12:07 Martin Friebe LazTarget post 1.2 => 1.4