View Issue Details

IDProjectCategoryView StatusLast Update
0020745FPCCompilerpublic2020-01-21 18:07
ReporterEric Heijnen Assigned ToMarco van de Voort  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionno change required 
Platformx86OSWindows 
Product Version2.5.1 
Summary0020745: Undefined Symbol: '<Windows api>'
DescriptionAn external library I am using for 32-bit windows (ufmod) does not work in FPC 2.5.1 anymore.

2.4.x does work fine.

I've attached the affected application and
Additional Informationxmplayer.lpr(14,1) Error: Undefined symbol: WaitForSingleObject
xmplayer.lpr(14,1) Error: Undefined symbol: CloseHandle
xmplayer.lpr(14,1) Error: Undefined symbol: CreateThread
xmplayer.lpr(14,1) Error: Undefined symbol: SetThreadPriority
xmplayer.lpr(14,1) Error: Undefined symbol: HeapAlloc
xmplayer.lpr(14,1) Error: Undefined symbol: HeapCreate
xmplayer.lpr(14,1) Error: Undefined symbol: HeapDestroy
xmplayer.lpr(14,1) Error: Undefined symbol: Sleep
xmplayer.lpr(14,1) Error: Undefined symbol: waveOutClose
xmplayer.lpr(14,1) Error: Undefined symbol: waveOutGetPosition
xmplayer.lpr(14,1) Error: Undefined symbol: waveOutOpen
xmplayer.lpr(14,1) Error: Undefined symbol: waveOutPrepareHeader
xmplayer.lpr(14,1) Error: Undefined symbol: waveOutReset
xmplayer.lpr(14,1) Error: Undefined symbol: waveOutUnprepareHeader
xmplayer.lpr(14,1) Error: Undefined symbol: waveOutWrite
xmplayer.lpr(14,1) Error: Undefined symbol: CreateFileA
xmplayer.lpr(14,1) Error: Undefined symbol: ReadFile
xmplayer.lpr(14,1) Error: Undefined symbol: SetFilePointer
xmplayer.lpr(14,1) Error: Undefined symbol: FindResourceA
xmplayer.lpr(14,1) Error: Undefined symbol: LoadResource
xmplayer.lpr(14,1) Error: Undefined symbol: SizeofResource
TagsNo tags attached.
Fixed in Revision
FPCOldBugId
FPCTarget
Attached Files

Relationships

related to 0019752 new Win64 linker error 

Activities

2011-11-25 01:38

 

xmplayer.zip (12,850 bytes)

Pierre Muller

2011-11-25 13:17

developer   ~0054449

Please provide a complete set of sources allowing to
compile your test, otherwise this is useless.

  ppc386 main.pas
results in
 Can't find unit xmlplayer_defines used by main
error

2011-11-25 16:22

 

xmplayerwithdefines.zip (13,083 bytes)

Eric Heijnen

2011-11-25 16:24

reporter   ~0054460

Sorry, forgot that it made use of a shared sourcefile of the main project. I've reuploaded the project with the missing file and tested it

Pierre Muller

2011-11-25 16:37

developer   ~0054461

Same problem as in bug report 19752, the reporter expects that using:
  procedure Test; external 'kernel32.dll'
in its pascal file
will create a global symbol named 'Test'
that is needed by libufmod.o file.
This was the case prior to a change allowing to import two library functions
from two different libraries with the same function export name.

  The problem is that your libufmod object file should itself contain the necessary imports.

Eric Heijnen

2011-11-25 17:38

reporter   ~0054462

Last edited: 2011-11-25 19:15

I don't have the sourcecode of libufmod (Well, I do, it's some assembler file..) but I've hacked around it the same way as in that other report: Using public name and writing a proxy for the functions

Reinier Olislagers

2014-06-04 16:55

developer   ~0075468

I wonder whether this issue can be closed no change required?

Marco van de Voort

2014-08-15 16:43

manager   ~0076610

No new info for years -> close.

OP seems to have solved his problem otherwise.

Marco van de Voort

2020-01-21 18:07

manager   ~0120614

Administrative close old pre 3.0.0 issues

Issue History

Date Modified Username Field Change
2011-11-25 01:38 Eric Heijnen New Issue
2011-11-25 01:38 Eric Heijnen File Added: xmplayer.zip
2011-11-25 09:21 Sergei Gorelkin Relationship added related to 0019752
2011-11-25 13:17 Pierre Muller Note Added: 0054449
2011-11-25 15:50 Jonas Maebe Status new => feedback
2011-11-25 16:22 Eric Heijnen File Added: xmplayerwithdefines.zip
2011-11-25 16:24 Eric Heijnen Note Added: 0054460
2011-11-25 16:37 Pierre Muller Note Added: 0054461
2011-11-25 17:38 Eric Heijnen Note Added: 0054462
2011-11-25 17:39 Eric Heijnen Note Edited: 0054462
2011-11-25 19:15 Eric Heijnen Note Edited: 0054462
2014-06-04 16:55 Reinier Olislagers Note Added: 0075468
2014-08-15 16:43 Marco van de Voort Note Added: 0076610
2014-08-15 16:43 Marco van de Voort Status feedback => resolved
2014-08-15 16:43 Marco van de Voort Resolution open => no change required
2014-08-15 16:43 Marco van de Voort Assigned To => Marco van de Voort
2020-01-21 18:07 Marco van de Voort Note Added: 0120614
2020-01-21 18:07 Marco van de Voort Status resolved => closed