View Issue Details

IDProjectCategoryView StatusLast Update
0020756LazarusLazReportpublic2014-10-15 07:11
ReporterindianajonesAssigned ToJesus Reyes 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version0.9.31 (SVN)Product Build 
Target Version1.4Fixed in Version1.3 (SVN) 
Summary0020756: Save as doesnt work
DescriptionSave as doesnt work for Mac OS.
Additional InformationFPC 2.4.4
Lazarus SVN 33630
TagsNo tags attached.
Fixed in Revision
LazTarget1.4
WidgetsetCarbon
Attached Files

Activities

Mattias Gaertner

2011-11-26 10:54

manager   ~0054486

It works here with OS X 10.6
fpc 2.7.1
Lazarus SVN 33793

What means "does not work"?

indianajones

2011-11-26 16:13

reporter   ~0054489

Yep, it is not definitive, whatever. I have tested with the latest svn 33798 and it saves the file but in the wrong directory. Changing directory doesnt effect in Mac OS.
Tested under GTK2 saves the file exact location if the directory location is changed.
One another point is that the default file extension is lrf under GTK2 which is different in MAC OS (frt).

Jesus Reyes

2014-10-15 07:11

developer   ~0078235

I cannot reproduce this problem using Mac OS X, maybe it was fixed when the filter index and change folder was fixed in r43061

Issue History

Date Modified Username Field Change
2011-11-26 06:37 indianajones New Issue
2011-11-26 06:37 indianajones Widgetset => Carbon
2011-11-26 10:54 Mattias Gaertner LazTarget => -
2011-11-26 10:54 Mattias Gaertner Note Added: 0054486
2011-11-26 10:54 Mattias Gaertner Status new => feedback
2011-11-26 10:54 Mattias Gaertner Description Updated
2011-11-26 16:13 indianajones Note Added: 0054489
2012-03-14 12:54 Vincent Snijders Status feedback => acknowledged
2012-03-15 08:07 Zeljan Rikalo Status acknowledged => assigned
2012-03-15 08:07 Zeljan Rikalo Assigned To => Jesus Reyes
2014-10-15 07:11 Jesus Reyes LazTarget - => 1.4
2014-10-15 07:11 Jesus Reyes Note Added: 0078235
2014-10-15 07:11 Jesus Reyes Status assigned => resolved
2014-10-15 07:11 Jesus Reyes Fixed in Version => 1.3 (SVN)
2014-10-15 07:11 Jesus Reyes Resolution open => fixed
2014-10-15 07:11 Jesus Reyes Target Version => 1.4