View Issue Details

IDProjectCategoryView StatusLast Update
0020803LazarusLCLpublic2011-12-16 22:59
ReporterAvishaiAssigned ToFelipe Monteiro de Carvalho 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.9.31 (SVN)Product Build 
Target VersionFixed in Version0.9.31 (SVN) 
Summary0020803: TNotebook, TPage, TPageControl and TTabSheet - BiDiMode
DescriptionTNotebook, TPage, TPageControl and TTabSheet need to have property BiDiMode and property ParentBiDiMode added to the Published Section. I did small test and it seems to work fine.
TagsNo tags attached.
Fixed in Revision34182, 34222
LazTarget-
WidgetsetWin32/Win64
Attached Files

Activities

Avishai

2011-12-03 19:13

reporter   ~0054674

Last edited: 2011-12-04 07:30

When I said it works fine, I meant as far as Text controls placed on them are concerned. The TNotebook and TPageControl do not reflect BiDiMode. Also need to add to TTabControl.

Avishai

2011-12-16 15:22

reporter   ~0055077

I think TNotebook and TPage still do not have property BiDiMode and property ParentBiDiMode in the Published section. These are only needed to pass to Child controls that have ParentBiDiMode:= True;

Felipe Monteiro de Carvalho

2011-12-16 15:39

developer   ~0055078

Indeed, I had forgotten about them because they are in another unit

Avishai

2011-12-16 15:43

reporter   ~0055079

Thank you Mr. Carvalho :)

Issue History

Date Modified Username Field Change
2011-12-03 17:03 Avishai New Issue
2011-12-03 17:03 Avishai Widgetset => Win32/Win64
2011-12-03 19:13 Avishai Note Added: 0054674
2011-12-03 19:15 Avishai Note Edited: 0054674
2011-12-03 19:15 Avishai Note Edited: 0054674
2011-12-04 07:30 Avishai Note Edited: 0054674
2011-12-04 12:42 Felipe Monteiro de Carvalho Status new => assigned
2011-12-04 12:42 Felipe Monteiro de Carvalho Assigned To => Felipe Monteiro de Carvalho
2011-12-14 15:51 Felipe Monteiro de Carvalho Fixed in Revision => 34182
2011-12-14 15:51 Felipe Monteiro de Carvalho LazTarget => -
2011-12-14 15:51 Felipe Monteiro de Carvalho Status assigned => resolved
2011-12-14 15:51 Felipe Monteiro de Carvalho Fixed in Version => 0.9.31 (SVN)
2011-12-14 15:51 Felipe Monteiro de Carvalho Resolution open => fixed
2011-12-14 16:39 Avishai Status resolved => closed
2011-12-16 15:22 Avishai Status closed => assigned
2011-12-16 15:22 Avishai Resolution fixed => reopened
2011-12-16 15:22 Avishai Note Added: 0055077
2011-12-16 15:39 Felipe Monteiro de Carvalho Fixed in Revision 34182 => 34182, 34222
2011-12-16 15:39 Felipe Monteiro de Carvalho Status assigned => resolved
2011-12-16 15:39 Felipe Monteiro de Carvalho Resolution reopened => fixed
2011-12-16 15:39 Felipe Monteiro de Carvalho Note Added: 0055078
2011-12-16 15:43 Avishai Note Added: 0055079
2011-12-16 22:59 Avishai Status resolved => closed