View Issue Details

IDProjectCategoryView StatusLast Update
0020835LazarusIDEpublic2013-08-31 13:45
ReporterMartin Friebe Assigned ToBart Broersma  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.9.30 
Summary0020835: ExpandFileNameUTF8 broken
DescriptionThe current implementation converts the filename using UTF8ToSys

This looses all chars in the filename that can not be encoded in the current sys encoding.

For example, I have an english w32. If a filename contains Russian chars, they are converted to "?"

Additional InformationThis can be tested, trying to open a file via drag and drop. It fails if file or folder contain such chars.


There are many other functions with the same issue.
TagsNo tags attached.
Fixed in Revisionr40842, r41035, r41038
LazTarget-
WidgetsetWin32/Win64
Attached Files

Relationships

related to 0020833 closedMartin Friebe Can't to debug application if path to project consists non-latin chars 
related to 0019483 closedJuha Manninen Lazarus cannot build to a directory which has unicode characters in its name 
related to 0011207 resolvedMattias Gaertner Invalid handling of non-english characters in filenames 
related to 0019058 resolvedBart Broersma Path Problem of 0.9.30 (released on 2011-03-22) 
related to 0020817 resolvedJuha Manninen TProcessUTF8 : "Failed to Passing Unicode Characters in TProcessUTF8.CommandLine" 
related to 0014504 closedVincent Snijders ExpandFileNameUTF8 does not work 

Activities

Martin Friebe

2011-12-07 15:29

manager   ~0054788

Due to this it is even impossible to open such a file via menu: file / open

Bart Broersma

2013-05-06 15:22

developer   ~0067517

FileUtil.ExpandFileNameUtf8 is now inlined to use LazFileUtils.ExpandFileNameUtf8, which internally uses the widestrings and widestring system calls.

Please close if OK.

Issue History

Date Modified Username Field Change
2011-12-07 15:11 Martin Friebe New Issue
2011-12-07 15:11 Martin Friebe LazTarget => -
2011-12-07 15:11 Martin Friebe Widgetset => Win32/Win64
2011-12-07 15:29 Martin Friebe Note Added: 0054788
2011-12-07 22:41 Juha Manninen Relationship added related to 0020833
2011-12-07 22:42 Juha Manninen Relationship added related to 0019483
2011-12-07 22:43 Juha Manninen Relationship added related to 0011207
2011-12-07 22:45 Juha Manninen Relationship added related to 0019058
2012-03-13 10:57 Vincent Snijders Status new => acknowledged
2012-03-13 11:24 Vincent Snijders Relationship added related to 0020817
2013-05-06 09:47 Juha Manninen Relationship added related to 0014504
2013-05-06 15:22 Bart Broersma Fixed in Revision => r40842, r41035, r41038
2013-05-06 15:22 Bart Broersma Note Added: 0067517
2013-05-06 15:22 Bart Broersma Status acknowledged => resolved
2013-05-06 15:22 Bart Broersma Resolution open => fixed
2013-05-06 15:22 Bart Broersma Assigned To => Bart Broersma
2013-08-31 13:45 Bart Broersma Status resolved => closed