View Issue Details

IDProjectCategoryView StatusLast Update
0020891PackagesCustom Drawnpublic2013-09-03 12:07
ReporterHeiko TietzeAssigned ToZeljan Rikalo 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionunable to reproduce 
Product VersionProduct Build 
Target VersionFixed in Version 
Summary0020891: Enabled icons are not shown with Qt on Darwin
DescriptionIcons that are enabled are not shown (blank area). The attached project has an actionlist, an imagelist with one 22x22 icon (tango iconset) and a toolbar with a button that is linked with this action/icon. You can toggle the enabled state and only if both are disabled the icon is shown.

Lazarus itself has no problem with icons (make clean all LCL_PLATFORM=qt FPC=.../2.4.4).
Additional InformationCompiler options: "-MObjFPC -Scghi -O1 -g -gl -vewnhi -l -Filib/i386-darwin -Fu/usr/local/src/Lazarus/lcl/units/i386-darwin/qt -Fu/usr/local/src/Lazarus/lcl/units/i386-darwin -Fu/usr/local/src/Lazarus/packager/units/i386-darwin -Fu. -FUlib/i386-darwin/ -dLCL -dLCLqt"

Free Pascal Compiler version 2.7.1 [2011/12/12] for i386

Lazarus 0.9.31 r34116M FPC 2.4.4 i386-darwin-qt

qmake -v
QMake version 2.01a
Using Qt version 4.7.4 in /Library/Frameworks

/usr/bin/sw_vers
ProductName: Mac OS X
ProductVersion: 10.6.4
BuildVersion: 10F569
TagsNo tags attached.
Fixed in Revision
LazTarget1.4
WidgetsetQT
Attached Files

Activities

2011-12-12 19:02

 

Archive.zip (7,434 bytes)

Zeljan Rikalo

2011-12-12 19:57

developer   ~0054998

@Heiko, just to be sure: Lazarus doesn't have problems with icons since I've fixed that problem on qt-mac (yesterday) - it was problem before ?

Heiko Tietze

2011-12-12 23:04

reporter   ~0055001

I wouldn't confirm a causal relation but yes, it has been fixed for Lazarus with yesterday's update.

Zeljan Rikalo

2011-12-13 08:08

developer   ~0055006

@Heiko, I cannot reproduce with your example. It works fine here.
MacOsX 10.4.11, Qt-4.6.3 (carbon) libQt4Pas 5.2.1

Zeljan Rikalo

2011-12-15 10:12

developer   ~0055047

@Heiko can you test agains svn r34201 ? There was problem with setting null region as clip region with coregraphics and quickdraw.

Zeljan Rikalo

2011-12-16 14:41

developer   ~0055075

@Heiko, now I don't understand few things:
1.Have you compiled qt 4.7.4 by yourself ? Because there's only 64bit cocoa version - so must rebuild Qt4pas for 64bit, in that case I cannot even start application , it crashes imediatelly ...
2.Binary Qt4Pas downloaded from Den's page is 32bit since I can link app,but it cannot start with qt-4.7.4 from nokia since it's 64 bit.
All tested on 10.6.8

Zeljan Rikalo

2011-12-16 17:44

developer   ~0055081

Ok, finally success build 64bit lazarus + Qt4Pas against qt-4.7.4

Zeljan Rikalo

2011-12-18 11:48

developer   ~0055101

@Heiko, I cannot reproduce it on mac (10.6.8 qt-4.7.4 (cocoa) 64bit + fpc-2.6.0 64bit) - it works fine.

Heiko Tietze

2012-02-04 15:03

reporter   ~0056455

I just checked and updated all. Fpc is now 2.6.0, Lazarus from latest svn, qt4pas new from Jan's site (v5.2), and qt45.pas replaced (the one with lcl delivered is 2.1, Jan's package contains 2.5). Qt framework itself is 4.7.
Still enabled buttons are not shown. Perhaps one shouldn't blame lcl or qt but either my installation or the fact that I'm running Darwin within a virtual box.
I think the thread can be closed.

Zeljan Rikalo

2012-02-04 15:31

developer   ~0056458

Please close.

Issue History

Date Modified Username Field Change
2011-12-12 19:02 Heiko Tietze New Issue
2011-12-12 19:02 Heiko Tietze Status new => assigned
2011-12-12 19:02 Heiko Tietze Assigned To => Felipe Monteiro de Carvalho
2011-12-12 19:02 Heiko Tietze File Added: Archive.zip
2011-12-12 19:02 Heiko Tietze Widgetset => QT
2011-12-12 19:54 Zeljan Rikalo Assigned To Felipe Monteiro de Carvalho => Zeljan Rikalo
2011-12-12 19:57 Zeljan Rikalo LazTarget => -
2011-12-12 19:57 Zeljan Rikalo Note Added: 0054998
2011-12-12 19:57 Zeljan Rikalo Status assigned => feedback
2011-12-12 23:04 Heiko Tietze Note Added: 0055001
2011-12-13 08:08 Zeljan Rikalo Note Added: 0055006
2011-12-13 08:08 Zeljan Rikalo Status feedback => acknowledged
2011-12-15 10:12 Zeljan Rikalo Note Added: 0055047
2011-12-15 10:12 Zeljan Rikalo Status acknowledged => feedback
2011-12-16 14:41 Zeljan Rikalo Note Added: 0055075
2011-12-16 14:41 Zeljan Rikalo Status feedback => acknowledged
2011-12-16 17:44 Zeljan Rikalo Note Added: 0055081
2011-12-18 11:48 Zeljan Rikalo Note Added: 0055101
2011-12-18 11:48 Zeljan Rikalo Status acknowledged => feedback
2012-02-04 11:43 Zeljan Rikalo LazTarget - => post 1.2
2012-02-04 15:03 Heiko Tietze Note Added: 0056455
2012-02-04 15:31 Zeljan Rikalo Status feedback => resolved
2012-02-04 15:31 Zeljan Rikalo Resolution open => unable to reproduce
2012-02-04 15:31 Zeljan Rikalo Note Added: 0056458
2013-03-29 10:51 Heiko Tietze Status resolved => closed
2013-09-03 12:07 Martin Friebe LazTarget post 1.2 => 1.4