View Issue Details

IDProjectCategoryView StatusLast Update
0000021Lazaruspublic2001-02-12 05:40
ReporterBug ImportAssigned ToMarc Weustink 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionno change required 
Product VersionProduct Build 
Target VersionFixed in Version 
Summary0000021: I can't run Lazarus !
DescriptionI get Lazarus from cvs on 13 january 2001. When i try 'make', i had these errors :

gtkproc.inc(134,49) Error: Incompatible type for arg no. 3: Got Array Of LONGINT, expected Array Of CHAR

when i looked at this file and this line, i saw :

 PS_DASH: gdk_gc_set_dashes(GC, 0, [4,4], 2);

I replaced it by :

 PS_DASH: gdk_gc_set_dashes(GC, 0, [0000004,0000004], 2);

and so for the 4 next lines, which were similar.

Then i can compile lazarus (with a lot of Notes and Warnings)!

But when i try to run it, i got a segmentation fault and this message :

LM_SCREENINIT called --> should go to GTKObject.Init
TODO: check this
[TCustomForm.Create] Resource 'TSPLASHFORM' not found
This is for information purposes only. This is not critical at this time.
[TCustomForm.Create] Resource 'TMAINIDE' not found
This is for information purposes only. This is not critical at this time.
[TCustomForm.Create] Resource 'TFINDDIALOG' not found
This is for information purposes only. This is not critical at this time.
Signature=TPF0
[TCustomForm.Create] Resource 'TOBJECTINSPECTOR' not found
This is for information purposes only. This is not critical at this time.
An unhandled exception occurred at 0x401E27D6 :
Access violation
  0x401E27D6
  0x401EAC73
  0x401CBBFB
  0x401EE0EF
  0x401ECC5A
  0x401955FD
  0x08091755
  0x4020C73F
  0x4021415A
  0xBFFFE630

must be nil
Exiting ControlClick
must be nil
Exiting ControlClick
must be nil
Exiting ControlClick
An unhandled exception occurred at 0x00000021 :
Access violation
  0x00000021
  0x080AD7DC
  0x080DD4BF
  0x080ADA8F
  0x080CF62B
  0x080CF5D7
  0x080B48F5
  0xBFFFF57C
An unhandled exception occurred at 0x080D86CA :
Access violation
  0x080D86CA
  0x3020200C
  0x00000000

[TgtkObject.Destroy] WARNING: There are 68 unreleased DCs and 332 unreleased GDIObjects
[TgtkObject.Destroy] WARNING: There are 6 messages left in the queue! I'll free them



What can i do ?
Additional InformationImported information
--------------------
Name: Denis Léger
Mail: denis.leger (at) laposte.net
TagsNo tags attached.
Fixed in Revision
LazTarget
WidgetsetGTK, Win32/Win64
Attached Files

Activities

Bug Import

2001-02-12 05:40

reporter   ~0000020

MWE

This is due to a difference in headers between the 1.0.4
and the 1.0.5 compiler. In order to get things working
one need a 1.0.5 compiler and the 1.0.5 libraries

Issue History

Date Modified Username Field Change
2001-01-13 00:00 Bug Import New Issue
2001-01-13 00:00 Bug Import Widgetset => GTK, Win32
2001-02-12 05:40 Bug Import Status new => assigned
2001-02-12 05:40 Bug Import Assigned To => Marc Weustink
2001-02-12 05:40 Bug Import Note Added: 0000020
2001-02-12 05:40 Bug Import Status new => closed
2001-02-12 05:40 Bug Import Resolution open => no change required