View Issue Details

IDProjectCategoryView StatusLast Update
0021050PackagesLazReportpublic2014-03-11 19:51
ReporterKoenraad Lelong Assigned ToJesus Reyes  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version0.9.30 
Target Version1.2.2Fixed in Version1.3 (SVN) 
Summary0021050: datafields not available if report is not on same form
DescriptionWhen placing a dataset in a datamodule and a frReport on a visible form, one can not select the fields of the dataset.
If the dataset is on the same form, the selection is available.
TagsNo tags attached.
Fixed in Revision44407
LazTarget1.2.2
WidgetsetWin32/Win64
Attached Files

Activities

2012-01-09 08:35

 

LazReport-bug.zip (130,762 bytes)

Roberto Carlos

2013-11-25 15:20

reporter   ~0071586

Error still persists on Lazarus 1.0.14 and Firebird 2.5 on Windows XP (32bit) and Windows 7 (64bit).
C:\Program Files\Firebird\Firebird_2_5\examples\empbuild\EMPLOYEE.FDB

Workaround is doing everything manually.
You will still NOT see the the field names on datafields, but the report will work without error messages:
----------------------------
procedure TForm1.Button1Click(Sender: TObject);
begin
  frDBDataSet1.DataSet := DataModule1.SQLQuery1;
  frReport1.DataType := dtDataSet;
  frReport1.Dataset := frDBDataSet1;
  frReport1.LoadFromFile('report123.lrf');
  frReport1.ShowReport;
end;
----------------------------
----------------------------
After "insert rectangle object", type manually (without selecting on DB field, because no field appears there):
----------------------------
[DataModule1.SQLQuery1."FIRST_NAME"]
----------------------------

Valdir Marcos

2013-12-23 03:44

reporter   ~0072012

Error still persists on RC1 of Lazarus 1.2 and Firebird 2.5 on Windows XP (32bit) and Windows 7 (64bit).

Jesus Reyes

2014-01-08 10:17

developer   ~0072299

You don't explicitly said if you are trying this in Lazarus at design time or in your program at run time using the LazReport designer.

The problem with the attached report is that there is no binding of the dataset through a TfrDBDataSet component. You need to first link TfrDBDataSet to a TDbf (which could be in a TDatamodule) and then link the TfrDBDataSet to the TfrReport via the Dataset property.

It works here, if it is still not working for you please correct the sample project and attach again.

Koenraad Lelong

2014-03-10 11:19

reporter  

LazReport-bug-new.zip (130,975 bytes)

Koenraad Lelong

2014-03-10 11:25

reporter   ~0073589

I just mentioned this on the Lazarus list :
When you use the query on the same form as the report, is not needed to add a TfrDBDataSet. And adding a TfrDBDataSet and connecting it to the query on the datamodule does not work. See LazReport-bug-new.zip.
I tried also using a datasource and connected this to the datamodule-query. No solution.

Now it's with Lazarus 1.2, at design time. Running WinXP. And it's the same problem with Firebird, wich I am using for my project.

Jesus Reyes

2014-03-11 19:51

developer   ~0073635

Please test

Issue History

Date Modified Username Field Change
2012-01-09 08:35 Koenraad Lelong New Issue
2012-01-09 08:35 Koenraad Lelong File Added: LazReport-bug.zip
2012-01-09 08:35 Koenraad Lelong Widgetset => Win32/Win64
2012-02-03 03:27 Jesus Reyes Status new => assigned
2012-02-03 03:27 Jesus Reyes Assigned To => Jesus Reyes
2013-11-25 15:20 Roberto Carlos Note Added: 0071586
2013-12-23 03:44 Valdir Marcos Note Added: 0072012
2014-01-08 10:17 Jesus Reyes LazTarget => -
2014-01-08 10:17 Jesus Reyes Note Added: 0072299
2014-01-08 10:17 Jesus Reyes Status assigned => feedback
2014-03-10 11:19 Koenraad Lelong File Added: LazReport-bug-new.zip
2014-03-10 11:25 Koenraad Lelong Note Added: 0073589
2014-03-10 11:25 Koenraad Lelong Status feedback => assigned
2014-03-11 19:51 Jesus Reyes Fixed in Revision => 44407
2014-03-11 19:51 Jesus Reyes LazTarget - => 1.2.2
2014-03-11 19:51 Jesus Reyes Note Added: 0073635
2014-03-11 19:51 Jesus Reyes Status assigned => resolved
2014-03-11 19:51 Jesus Reyes Fixed in Version => 1.3 (SVN)
2014-03-11 19:51 Jesus Reyes Resolution open => fixed
2014-03-11 19:51 Jesus Reyes Target Version => 1.2.2