View Issue Details

IDProjectCategoryView StatusLast Update
0021052LazarusLCLpublic2012-01-09 17:10
ReporterReinhard BergerAssigned ToZeljan Rikalo 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.9.30.1 (SVN)Product Build 
Target VersionFixed in Version0.9.31 (SVN) 
Summary0021052: No "OnDropFiles" event in QT when the drag cames from a GTK2 program.
DescriptionWhen using a QT Form and you drop some files from a GTK2 program to the QT Form, no "onDropFiles" event is fireed.

If the Drag Source is a QT program , the event is correctly fireed.

If the form is using GTK2 then both GTK2 and QT Programs can drop.

Tried it out with a QT form and the GTK2 based Filemanger "pcmanfm" - dropping does not work.

Tried it out with a QT form and the KDE filemanager "Dolphin" - dropping works.
TagsNo tags attached.
Fixed in Revision34683
LazTarget0.99.0
Widgetset
Attached Files

Activities

2012-01-09 16:12

 

DragDrop-QT.tar.gz (314,536 bytes)

Zeljan Rikalo

2012-01-09 16:25

developer   ~0055623

maybe pcmanfm does not provide xorg standard events ? This is not general bug gtk2 <> qt since from thunar (file mgr of xfce) and nautilus (gnome) event is fired correctly. I'll try to find pcmanfm rpms for fedora and see what's up.

Zeljan Rikalo

2012-01-09 16:28

developer   ~0055624

Sorry, I've tested your example without changing ws, it was gtk2...now I see:
only nautils works fine, but thunar and pcmanfm not.

Zeljan Rikalo

2012-01-09 16:37

developer   ~0055625

Please test and close if ok.

Reinhard Berger

2012-01-09 17:10

reporter   ~0055629

Works.
Thx

Issue History

Date Modified Username Field Change
2012-01-09 16:12 Reinhard Berger New Issue
2012-01-09 16:12 Reinhard Berger File Added: DragDrop-QT.tar.gz
2012-01-09 16:14 Zeljan Rikalo Status new => assigned
2012-01-09 16:14 Zeljan Rikalo Assigned To => Zeljan Rikalo
2012-01-09 16:25 Zeljan Rikalo LazTarget => -
2012-01-09 16:25 Zeljan Rikalo Note Added: 0055623
2012-01-09 16:25 Zeljan Rikalo Status assigned => feedback
2012-01-09 16:28 Zeljan Rikalo Note Added: 0055624
2012-01-09 16:28 Zeljan Rikalo Status feedback => confirmed
2012-01-09 16:37 Zeljan Rikalo Fixed in Revision => 34683
2012-01-09 16:37 Zeljan Rikalo LazTarget - => 0.99.0
2012-01-09 16:37 Zeljan Rikalo Status confirmed => resolved
2012-01-09 16:37 Zeljan Rikalo Fixed in Version => 0.9.31 (SVN)
2012-01-09 16:37 Zeljan Rikalo Resolution open => fixed
2012-01-09 16:37 Zeljan Rikalo Note Added: 0055625
2012-01-09 16:37 Zeljan Rikalo Target Version => 0.99.0
2012-01-09 17:10 Reinhard Berger Status resolved => closed
2012-01-09 17:10 Reinhard Berger Note Added: 0055629