View Issue Details

IDProjectCategoryView StatusLast Update
0021140LazarusLCLpublic2012-02-08 20:53
ReporterszaliAssigned ToMartin Friebe 
PrioritynormalSeveritytrivialReproducibilityalways
Status resolvedResolutionfixed 
Product Version0.9.30.3 (SVN)Product Build 
Target Version1.0.0Fixed in Version0.9.31 (SVN) 
Summary0021140: ScrollBox view should redraw continuously while scrollbar is used. Affects also Lazarus menu editor
DescriptionPlease repaint the menu preview at every bit of scrolling in the menu editor. At least on Windows, the preview only draws when I release the mouse button when finished scrolling. (It is an outdated practice to redraw only when scrolling is finished.)

[Edit] Summary changed by Juha. It referred to menu editor, now it refers to ScrollBox.
TagsNo tags attached.
Fixed in Revision35244
LazTarget1.2
WidgetsetGTK, GTK 2, Win32/Win64, WinCE, Carbon, Cocoa, fpGUI
Attached Files

Activities

Zeljan Rikalo

2012-02-04 11:00

developer   ~0056319

It works fine with qt. Please someone test carbon and retest win32 to see what's up.

Zeljan Rikalo

2012-02-07 20:44

developer   ~0056639

Maybe it's fixed by adding csCaptureMouse to TScrollBox in r35225

Juha Manninen

2012-02-07 21:33

developer   ~0056642

No Zeljan, it doesn't work with QT, nor the other widgetsets.
When you grab the scrollbar slider and move it, the box is not updated.
Redraw happens only after you release the slider.

Most modern GUIs draw it continuously.

Martin Friebe

2012-02-07 22:06

manager   ~0056645

At least on W32 it works, if you set the "Tracking" property of each scrollbar to true (Object inspector)

Zeljan Rikalo

2012-02-08 07:50

developer   ~0056652

Then please someone attach example which shows drawing inconsitencies, I'll try to fix it.

Juha Manninen

2012-02-08 09:14

developer   ~0056656

Zeljan, Lazarus menu editor.
I have not tested "Tracking" property though, and now I can't test because I must go...

Martin Friebe

2012-02-08 20:53

manager   ~0056667

The default for ScrollBoxes is Tracking = False
Developpers can set that for their own apps

In the IDE this has been enabled. The menu editor now scrolls while dragging.

Issue History

Date Modified Username Field Change
2012-01-23 19:49 szali New Issue
2012-01-23 19:49 szali Widgetset => Win32/Win64
2012-01-24 16:25 Juha Manninen LazTarget => -
2012-01-24 16:25 Juha Manninen Summary Make menu preview redraw continuously when scrolling with scrollbars in Lazarus menu editor => ScrollBox view should redraw continuously while scrollbar is used. Affects also Lazarus menu editor
2012-01-24 16:25 Juha Manninen Description Updated
2012-01-24 16:31 Juha Manninen Widgetset Win32/Win64 => GTK, GTK 2, Win32/Win64, WinCE, Carbon, Cocoa, QT, fpGUI
2012-01-24 16:31 Juha Manninen Category IDE => LCL
2012-02-04 11:00 Zeljan Rikalo LazTarget - => 1.2
2012-02-04 11:00 Zeljan Rikalo Widgetset GTK, GTK 2, Win32/Win64, WinCE, Carbon, Cocoa, QT, fpGUI => GTK, GTK 2, Win32/Win64, WinCE, Carbon, Cocoa, fpGUI
2012-02-04 11:00 Zeljan Rikalo Note Added: 0056319
2012-02-07 20:44 Zeljan Rikalo Note Added: 0056639
2012-02-07 21:33 Juha Manninen Note Added: 0056642
2012-02-07 22:06 Martin Friebe Note Added: 0056645
2012-02-08 07:50 Zeljan Rikalo Note Added: 0056652
2012-02-08 07:50 Zeljan Rikalo Status new => feedback
2012-02-08 09:14 Juha Manninen Note Added: 0056656
2012-02-08 20:51 Martin Friebe Status feedback => assigned
2012-02-08 20:51 Martin Friebe Assigned To => Martin Friebe
2012-02-08 20:53 Martin Friebe Fixed in Revision => 35244
2012-02-08 20:53 Martin Friebe Status assigned => resolved
2012-02-08 20:53 Martin Friebe Fixed in Version => 0.9.31 (SVN)
2012-02-08 20:53 Martin Friebe Resolution open => fixed
2012-02-08 20:53 Martin Friebe Note Added: 0056667
2012-02-08 20:53 Martin Friebe Target Version => 1.0.0