View Issue Details

IDProjectCategoryView StatusLast Update
0021161LazarusLCLpublic2012-02-06 04:38
Reportersamuel herzogAssigned ToPaul Ishenin 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Platformwin32OSwindows xpOS Versionxp sp3
Product Version0.9.30.1 (SVN)Product BuildLazarus 0.9.31 r34889 FPC 2.6.1  
Target VersionFixed in Version0.9.31 (SVN) 
Summary0021161: Event TrackBar.OnChange is not fired.
DescriptionThe event handler assigened to Trackbar.OnChange is not executed.
Steps To Reproduce1.) start lazarus.
2.) open the example project C:\lazarus\examples\motiongraphics
3.) set a break-point into TForm1.trackSpeedChange
4.) run the application an change the trackbar position.

On my machine, the break-point is never reached.
TagsNo tags attached.
Fixed in Revision35167
LazTarget0.99.0
WidgetsetWin32/Win64
Attached Files

Activities

Zeljan Rikalo

2012-01-31 08:17

developer   ~0056185

Please attach sample project.

samuel herzog

2012-02-03 07:13

developer   ~0056275

No sample project needed because lazarus contains already the sample project.


See "Steps to reproduced".

It says: 2.) open the example project C:\lazarus\examples\motiongraphics

Zeljan Rikalo

2012-02-04 14:47

developer   ~0056454

@Paul please see what to do with this.

Paul Ishenin

2012-02-06 04:20

manager   ~0056554

That was a bug in project options and customdrawn widgetset. Project options was set to use customdrawn widgetset instead of default one. Also an unimplemented feature of customdrawn widgetset does not allow to change the speed of rotation.

Please test and close if ok.

samuel herzog

2012-02-06 04:38

developer   ~0056555

Tested->OK

Thanks, works fine now.

Issue History

Date Modified Username Field Change
2012-01-26 06:43 samuel herzog New Issue
2012-01-26 06:43 samuel herzog LazTarget => -
2012-01-26 06:43 samuel herzog Widgetset => Win32/Win64
2012-01-31 08:17 Zeljan Rikalo Note Added: 0056185
2012-01-31 08:17 Zeljan Rikalo Status new => feedback
2012-02-03 07:13 samuel herzog Note Added: 0056275
2012-02-04 14:47 Zeljan Rikalo Note Added: 0056454
2012-02-04 14:47 Zeljan Rikalo Assigned To => Paul Ishenin
2012-02-04 14:47 Zeljan Rikalo Status feedback => assigned
2012-02-04 16:17 Maxim Ganetsky LazTarget - => 0.99.0
2012-02-04 16:17 Maxim Ganetsky Target Version 0.99.1 (SVN) => 0.99.0
2012-02-06 04:20 Paul Ishenin Fixed in Revision => 35167
2012-02-06 04:20 Paul Ishenin Status assigned => resolved
2012-02-06 04:20 Paul Ishenin Fixed in Version => 0.9.31 (SVN)
2012-02-06 04:20 Paul Ishenin Resolution open => fixed
2012-02-06 04:20 Paul Ishenin Note Added: 0056554
2012-02-06 04:38 samuel herzog Status resolved => closed
2012-02-06 04:38 samuel herzog Note Added: 0056555