View Issue Details

IDProjectCategoryView StatusLast Update
0021207LazarusDatabase Componentspublic2012-05-14 15:46
Reporterwillians cleytonAssigned ToJoost van der Sluis 
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionduplicate 
PlatformArmOSAndroidOS Version2.2 / 3.0
Product VersionProduct Build 
Target VersionFixed in Version 
Summary0021207: Example androidlcl does not run when you add a DataSource
DescriptionI managed to compile the example folder androidlcl - lazarus, install and run the Android emulator with no problems.

But when I add a DataSource in the example (image DataSource.JPG) and when I run the Android emulator appears the error described in the attached file adb_logcat.txt.

Any idea what might be happening?
Steps To ReproduceAdd the DataSource example, compile and run.

Additional InformationI used the VM available at: http://sourceforge.net/projects/p-tools/files/Lazarus_for_Android_VM_Image/snapshot_30_dez_2011/
TagsNo tags attached.
Fixed in Revision
LazTarget-
Widgetset
Attached Files

Relationships

duplicate of 0021208 resolvedFelipe Monteiro de Carvalho FPC Example androidlcl does not run when you add a DataSource 

Activities

2012-02-01 18:00

 

LazarusAndroid.zip (127,105 bytes)

Felipe Monteiro de Carvalho

2012-05-14 15:46

developer   ~0059583

I fixed this issue in bug 21208

You can install the new compiler snapshot with this fix following this instructions: http://wiki.lazarus.freepascal.org/Custom_Drawn_Interface/Android#Using_the_pre-compiled_compiler_in_Linux

There is currently no VM Image with this newer compiler, but there will be one.

For further asking how to use the compiler snapshot use the forum.

Issue History

Date Modified Username Field Change
2012-02-01 18:00 willians cleyton New Issue
2012-02-01 18:00 willians cleyton Status new => assigned
2012-02-01 18:00 willians cleyton Assigned To => Joost van der Sluis
2012-02-01 18:00 willians cleyton File Added: LazarusAndroid.zip
2012-02-01 18:37 Marco van de Voort Project FPC => Lazarus
2012-05-14 15:46 Felipe Monteiro de Carvalho LazTarget => -
2012-05-14 15:46 Felipe Monteiro de Carvalho Relationship added duplicate of 0021208
2012-05-14 15:46 Felipe Monteiro de Carvalho Duplicate ID 0 => 21208
2012-05-14 15:46 Felipe Monteiro de Carvalho Status assigned => resolved
2012-05-14 15:46 Felipe Monteiro de Carvalho Resolution open => duplicate
2012-05-14 15:46 Felipe Monteiro de Carvalho Note Added: 0059583