View Issue Details

IDProjectCategoryView StatusLast Update
0021241LazarusIDEpublic2020-03-30 21:21
ReporterEverton Vieira Assigned ToJuha Manninen  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionunable to reproduce 
Product Version0.9.30.2 
Summary0021241: Code Explorer doesn't follow the cursor when is a procedure that is inside a type.
DescriptionExample:

  TfmExample = class(TForm)
    procedure FormCreate(Sender: TObject);
  private
  public
  end;

procedure TfmExample.FormCreate(Sender: TObject);
begin

end;
Additional InformationWhen the cursor is inside the FormCreate, the CodeExplorer doesn't go to corresponded procedure that are inside the Types.
TagsNo tags attached.
Fixed in Revision
LazTarget-
WidgetsetWin32/Win64
Attached Files

Activities

Mattias Gaertner

2012-02-07 17:41

manager   ~0056626

Have enabled the option "Follow cursor"?
Then you should see in the popup menu a "Jump to" and "Jump to implementation" to jump to the two places.

Zeljan Rikalo

2012-02-07 19:21

developer   ~0056628

@Everton, please give feedback for Mattias note.

Everton Vieira

2012-02-09 10:49

reporter   ~0056674

Yes, i`ve enabled. But they can find out when is inside the type TForm, is what i has been experiencing. The jump doesn`t work because they don't find.

Mattias Gaertner

2012-02-09 10:59

manager   ~0056675

Where exactly is the caret in the source editor?
Do you see the two menu items "jump" and "jump to implementation"?

Everton Vieira

2012-02-09 11:48

reporter   ~0056676

Brother, they don't select the proper item in the tree view so how can be a pop menu to jump without the proper item be selected? The jump isn`t the issue. The issue is about to select the proper item in the tree view. That is what isn`t happening.

When the cursor goes to the type description they select right the item in the tree view.
But when the cursor goes to the code they don`t select the corresponding item in the tree view.

What i think was supposed to happen, right?

Everton Vieira

2012-02-09 11:52

reporter   ~0056677

Last edited: 2012-02-09 11:54

I`ve wrote the issue by first badly, very easy to be misunderstand. Very sorry about it.

Everton Vieira

2012-02-10 15:33

reporter   ~0056722

Since you will go change this unit, don`t you wanna make some option for the code explorer automatically open all the nodes?

Juha Manninen

2020-03-30 21:21

developer   ~0121779

I cannot reproduce this issue. The Code Explorer view is updated when I move cursor in source editor. It can be in the method declaration or implementation, works both ways.
Note: Code Explorer gets updated only when option "Refresh automatically" -> "On idle" is selected.
Resolving.

Issue History

Date Modified Username Field Change
2012-02-07 17:22 Everton Vieira New Issue
2012-02-07 17:22 Everton Vieira Widgetset => Win32/Win64
2012-02-07 17:41 Mattias Gaertner Note Added: 0056626
2012-02-07 19:21 Zeljan Rikalo LazTarget => -
2012-02-07 19:21 Zeljan Rikalo Note Added: 0056628
2012-02-07 19:21 Zeljan Rikalo Status new => feedback
2012-02-09 10:49 Everton Vieira Note Added: 0056674
2012-02-09 10:59 Mattias Gaertner Note Added: 0056675
2012-02-09 11:48 Everton Vieira Note Added: 0056676
2012-02-09 11:52 Everton Vieira Note Added: 0056677
2012-02-09 11:54 Everton Vieira Note Edited: 0056677
2012-02-09 21:14 Mattias Gaertner Status feedback => assigned
2012-02-09 21:14 Mattias Gaertner Assigned To => Mattias Gaertner
2012-02-10 15:33 Everton Vieira Note Added: 0056722
2014-11-30 11:18 Juha Manninen Project Patches => Lazarus
2020-03-30 21:21 Juha Manninen Assigned To Mattias Gaertner => Juha Manninen
2020-03-30 21:21 Juha Manninen Status assigned => resolved
2020-03-30 21:21 Juha Manninen Resolution open => unable to reproduce
2020-03-30 21:21 Juha Manninen Widgetset Win32/Win64 => Win32/Win64
2020-03-30 21:21 Juha Manninen Note Added: 0121779