View Issue Details

IDProjectCategoryView StatusLast Update
0021270LazarusIDEpublic2014-10-14 22:46
ReporterEmin BorborAssigned ToPaul Ishenin 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.9.31 (SVN)Product Build 
Target VersionFixed in Version0.9.31 (SVN) 
Summary0021270: Lazarus IDE saves window left position to top and vise versa
DescriptionAfter existing IDE, check environmentoptions.xml for example SourceNotebook node or any other window position. Left and top are set to each other's values in xml:

     <SourceNotebook>
        <WindowPlacement Value="RestoreWindowGeometry"/>
        <CustomPosition Left="122" Top="251" Width="962" Height="504"/>
        <WindowState Value="Normal"/>
        <Caption Value="SourceNotebook"/>
      </SourceNotebook>

So after starting the IDE your window positions are messed up.

TagsNo tags attached.
Fixed in Revision35409,35410
LazTarget-
WidgetsetWin32/Win64
Attached Files

Relationships

related to 0021301 resolvedJuha Manninen Lazarus CCR After installing manual docker, source editor window position and dimension save problem 

Activities

Bart Broersma

2012-02-12 23:33

developer   ~0056784

Lazarus 0.9.31 r35332 FPC 2.6.0 i386-win32-win32/win64
It seems that changes to SourceEditor window are not saved (change position of SoureEditor, quit Lazarus: no change in environmentoptions.xml), except when explicitely set via Tools -> Options -> Window.
To me it seems that Left and Top are not mixed up b.t.w.
Main IDE window, Messages and OI behave as expected.

Emin Borbor

2012-02-13 21:27

reporter   ~0056803

Lazarus: 0.9.31 SVN rev: 35297 FPC: 2.6.1 i386-win32-win32/win64
Downloaded from Snapshots url

Below, xml nodes extracted from environmentoptions.xml before and after exiting Lazarus. I started with the first position and move messages window few pixels to right and exit Lazarus. Left is saved to top and top is saved to left.

      <MessagesView>
        <WindowPlacement Value="RestoreWindowGeometry"/>
        <WindowState Value="Normal"/>
        <Visible Value="True"/>
        <Caption Value="Messages"/>
        <CustomPosition Left="250" Top="556" Width="699" Height="100"/>
      </MessagesView>

      <MessagesView>
        <WindowPlacement Value="RestoreWindowGeometry"/>
        <WindowState Value="Normal"/>
        <Visible Value="True"/>
        <Caption Value="Messages"/>
        <CustomPosition Left="556" Top="251" Width="698" Height="100"/>
      </MessagesView>

Also note that sometimes Width and Height mixed as well.

Bart Broersma

2012-02-13 23:34

developer   ~0056805

I cannot reproduce that (note 56803) at all (r35332), I also cannot see any revision between 35979 and 35332 that would explain the difference between our observations.

Juha Manninen

2012-02-16 12:34

developer   ~0056854

Strange, here the source editor and messages windows opened always in a wrong place. I tried to bisect the revision causing it but then the problem disappeared completely. Now it works always correctly.

Try deleting your local Lazarus configuration. Does it help?

Bart Broersma

2012-02-16 20:05

developer   ~0056862

@Juha: does your Lazarus save the position of the SourceEditor window (see note 0056784)?

Paul Ishenin

2012-02-17 10:22

manager   ~0056874

Please test and close if ok.

Emin Borbor

2012-02-17 20:15

reporter   ~0056900

Thank you, windows now keep correct position/size on IDE exit/start. tested with r35410 from SVN.

Issue History

Date Modified Username Field Change
2012-02-12 20:58 Emin Borbor New Issue
2012-02-12 20:58 Emin Borbor Widgetset => Win32/Win64
2012-02-12 23:33 Bart Broersma Note Added: 0056784
2012-02-13 21:27 Emin Borbor Note Added: 0056803
2012-02-13 23:34 Bart Broersma Note Added: 0056805
2012-02-16 12:34 Juha Manninen Note Added: 0056854
2012-02-16 20:05 Bart Broersma Note Added: 0056862
2012-02-17 10:22 Paul Ishenin Fixed in Revision => 35409,35410
2012-02-17 10:22 Paul Ishenin LazTarget => -
2012-02-17 10:22 Paul Ishenin Status new => resolved
2012-02-17 10:22 Paul Ishenin Fixed in Version => 0.9.31 (SVN)
2012-02-17 10:22 Paul Ishenin Resolution open => fixed
2012-02-17 10:22 Paul Ishenin Assigned To => Paul Ishenin
2012-02-17 10:22 Paul Ishenin Note Added: 0056874
2012-02-17 20:15 Emin Borbor Note Added: 0056900
2012-02-17 20:15 Emin Borbor Status resolved => closed
2014-10-14 22:46 Juha Manninen Relationship added related to 0021301