View Issue Details

IDProjectCategoryView StatusLast Update
0021302LazarusLCLpublic2014-10-24 11:14
Reporterindianajones Assigned ToZeljan Rikalo  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version0.9.31 (SVN) 
Summary0021302: TStatusBar color property doesnt work.
DescriptionChanging TStatusBar color doesnt paint the StatusBar area.
Also tested with the GTK+ and paint either.
Additional InformationFPC 2.6.0
Lazarus SVN 2.6.0
TagsNo tags attached.
Fixed in Revision44933,45004
LazTarget1.4
WidgetsetGTK 2, Carbon, QT
Attached Files

Relationships

related to 0026838 closedMike Thompson Statusbar.Color does not work under win32 
related to 0026809 closedVincent Snijders Error in some LCL components. 

Activities

indianajones

2012-02-16 15:52

reporter   ~0056859

Also tested with the GTK+ and does not paint either.

Zeljan Rikalo

2014-05-06 16:31

developer   ~0074805

Qt is fixed in r44933, gtk and carbon still remains.

Zeljan Rikalo

2014-05-06 16:32

developer   ~0074806

You can test qt if you want.

Zeljan Rikalo

2014-05-10 21:44

developer   ~0074891

Gtk2 also works. Don't know yet if it's possible to make it work on carbon.

Zeljan Rikalo

2014-05-10 21:47

developer   ~0074892

I've unassigned this issue from me since Qt and Gtk2 works fine. Someone should look into Carbon if it works there (maybe fixed in the meantime).

Zeljan Rikalo

2014-05-11 12:45

developer   ~0074909

Qt and Gtk2 works, carbon does not support TStatusBar.Color, added it to the issues.xml.
Please close if ok.

Issue History

Date Modified Username Field Change
2012-02-16 15:51 indianajones New Issue
2012-02-16 15:51 indianajones Widgetset => Carbon
2012-02-16 15:52 indianajones Note Added: 0056859
2012-03-13 08:11 Zeljan Rikalo Status new => assigned
2012-03-13 08:11 Zeljan Rikalo Assigned To => Zeljan Rikalo
2012-03-17 13:22 Zeljan Rikalo LazTarget => 1.2
2012-03-17 13:22 Zeljan Rikalo Widgetset Carbon => GTK 2, Carbon, QT
2012-03-17 13:22 Zeljan Rikalo Description Updated
2012-03-17 13:22 Zeljan Rikalo Additional Information Updated
2014-01-14 15:16 Martin Friebe LazTarget 1.2 => 1.4
2014-05-06 16:31 Zeljan Rikalo Fixed in Revision => 44933
2014-05-06 16:31 Zeljan Rikalo Note Added: 0074805
2014-05-06 16:31 Zeljan Rikalo Status assigned => resolved
2014-05-06 16:31 Zeljan Rikalo Resolution open => fixed
2014-05-06 16:32 Zeljan Rikalo Note Added: 0074806
2014-05-06 16:32 Zeljan Rikalo Status resolved => feedback
2014-05-10 21:44 Zeljan Rikalo Note Added: 0074891
2014-05-10 21:44 Zeljan Rikalo Status feedback => assigned
2014-05-10 21:47 Zeljan Rikalo Assigned To Zeljan Rikalo =>
2014-05-10 21:47 Zeljan Rikalo Note Added: 0074892
2014-05-11 01:09 Bart Broersma Status assigned => acknowledged
2014-05-11 12:45 Zeljan Rikalo Fixed in Revision 44933 => 44933,45004
2014-05-11 12:45 Zeljan Rikalo Note Added: 0074909
2014-05-11 12:45 Zeljan Rikalo Status acknowledged => resolved
2014-05-11 12:45 Zeljan Rikalo Assigned To => Zeljan Rikalo
2014-10-09 22:47 Mike Thompson Relationship added related to 0026838
2014-10-24 11:14 Juha Manninen Relationship added related to 0026809