View Issue Details

IDProjectCategoryView StatusLast Update
0021305LazarusDatabase Componentspublic2012-03-17 09:39
ReportergeniAssigned ToJesus Reyes 
PrioritynormalSeveritytrivialReproducibilityalways
Status resolvedResolutionduplicate 
Platformi386OSLinux UbuntuOS Version10.10
Product VersionProduct Build 
Target Version1.2.0Fixed in Version0.9.31 (SVN) 
Summary0021305: The DBNavigator is not running at design time
DescriptionThe DBNavigator is not running at design time. The buttons remain visible when removing the objectinspector
TagsNo tags attached.
Fixed in Revision
LazTarget1.2
Widgetset
Attached Files

Relationships

duplicate of 0020820 resolvedJesus Reyes dbnavigator.VisibleButtons (not remove button on the form) 

Activities

geni

2012-03-04 02:36

reporter   ~0057253

Let's see if that helps:

In buttonPanel unit (component TButtonPanel - Misc), has the property ShowButtons.

It works correctly!

At design time the buttons are visible or not.

In the TDBNavigator component, it does not, true or false in design time, the buttons are always visible.

Issue History

Date Modified Username Field Change
2012-02-16 20:17 geni New Issue
2012-02-16 20:17 geni Status new => assigned
2012-02-16 20:17 geni Assigned To => Joost van der Sluis
2012-02-16 20:22 Jonas Maebe FPCOldBugId => 0
2012-02-16 20:22 Jonas Maebe Assigned To Joost van der Sluis =>
2012-02-16 20:22 Jonas Maebe Status assigned => new
2012-02-16 20:22 Jonas Maebe Project FPC => Lazarus
2012-03-04 02:36 geni Note Added: 0057253
2012-03-13 08:06 Zeljan Rikalo LazTarget => 1.2
2012-03-13 08:06 Zeljan Rikalo Status new => acknowledged
2012-03-13 08:06 Zeljan Rikalo Target Version => 1.2.0
2012-03-17 09:36 Jesus Reyes Status acknowledged => assigned
2012-03-17 09:36 Jesus Reyes Assigned To => Jesus Reyes
2012-03-17 09:38 Jesus Reyes Relationship added duplicate of 0020820
2012-03-17 09:39 Jesus Reyes Status assigned => resolved
2012-03-17 09:39 Jesus Reyes Fixed in Version => 0.9.31 (SVN)
2012-03-17 09:39 Jesus Reyes Resolution open => duplicate
2013-03-06 14:04 Dietrich Hoppe Issue cloned: 0024000