View Issue Details

IDProjectCategoryView StatusLast Update
0021331LazarusLCLpublic2017-11-11 21:01
ReporterPaul Ishenin Assigned ToMattias Gaertner  
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionduplicate 
Product Version0.9.31 (SVN) 
Summary0021331: A hidden minimized form can't be shown again
DescriptionIf a form was hidden with WindowState = wsMinimzed it will not show again
TagsNo tags attached.
Fixed in Revision
LazTarget-
Widgetset
Attached Files

Relationships

duplicate of 0018514 resolvedOndrej Pokorny show on minimized form 
related to 0021603 new Cannot create and show on taskbar already minimized form 

Activities

2012-02-21 02:19

 

Zeljan Rikalo

2012-03-17 18:17

developer   ~0057782

What about using same code as we use in ShowOnTop ?
  if WindowState = wsMinimized then
    WindowState := wsNormal;
  Visible := True;
  BringToFront;

Besides that I don't see any difference between those two routines.

Sandro Cumerlato

2014-09-20 21:23

reporter   ~0077466

if WindowState = wsMinimized then
    WindowState := wsNormal;

...we should restore WindowState to the previous window state (the one before wsMinimized: wsNormal, wsMaximized or wsFullScreen):

  if WindowState = wsMinimized then
    WindowState := *FPreviousWindowState*;

CudaText man

2017-03-12 09:45

reporter   ~0098830

It were some changes to hidden/minimized forms in 1.7
So maybe the issue fixed?

Juha Manninen

2017-04-24 21:29

developer   ~0099879

Resolving as duplicate.

Issue History

Date Modified Username Field Change
2012-02-21 02:19 Paul Ishenin New Issue
2012-02-21 02:19 Paul Ishenin File Added: show_minimized_form.zip
2012-02-21 02:19 Paul Ishenin LazTarget => -
2012-02-21 02:19 Paul Ishenin Status new => assigned
2012-02-21 02:19 Paul Ishenin Assigned To => Mattias Gaertner
2012-03-13 00:57 Paul Ishenin Relationship added duplicate of 0018514
2012-03-17 18:17 Zeljan Rikalo Note Added: 0057782
2014-09-20 21:23 Sandro Cumerlato Note Added: 0077466
2017-03-12 09:45 CudaText man Note Added: 0098830
2017-04-24 21:29 Juha Manninen Note Added: 0099879
2017-04-24 21:29 Juha Manninen Status assigned => resolved
2017-04-24 21:29 Juha Manninen Resolution open => duplicate
2017-11-11 21:01 Juha Manninen Relationship added related to 0021603