View Issue Details

IDProjectCategoryView StatusLast Update
0021369LazarusLCLpublic2013-02-21 09:11
ReporterPiotr KarasinskiAssigned ToJesus Reyes 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version0.9.31 (SVN)Product Build 
Target Version1.2.0Fixed in Version1.1 (SVN) 
Summary0021369: [Carbon] TSaveDialog.Filter seems to be ignored
DescriptionSetting the TSaveDialog.Filter adds filter to the Format combo box on the dialog, but the the box has always "Default" selected initially. Moreover all the files are grayed out, despite the selected filter - it just doesn't seem to matter.
Anyway on Delphi this works as expected - filters the file list and selects the assigned filter as default, so if this is not some OS specific convention, then it's a bug I guess.
Uploaded an example program opening TSaveDialog with custom filter in FormCreate.
Additional InformationI observed this on Mac OS X 10.7.3.
TagsCarbon, TSaveDialog
Fixed in Revision40343
LazTarget1.2
WidgetsetCarbon
Attached Files

Activities

2012-02-24 12:28

 

SaveDialogFilterTest.tbz2 (79,187 bytes)

Jesus Reyes

2013-02-20 07:07

developer   ~0065775

Last edited: 2013-02-20 07:08

View 2 revisions

I checked and at least since r40343, the filter index is reported correctly. About the fact that selecting a filter from the list (or having "default") selected will keep items grayed out, that's normal, as this is a SaveDialog, if it was a OpenDialog it would be indeed a problem. So it seems this is how it's supposed to be. I tested this with a native application, TextEdit. so I guess it's a system convention after all, and not as like in windows where you only see the list of files that matches the filter extension.

I think there is nothing more left in this report, but if there is, reopen it again and explain

Issue History

Date Modified Username Field Change
2012-02-24 12:28 Piotr Karasinski New Issue
2012-02-24 12:28 Piotr Karasinski File Added: SaveDialogFilterTest.tbz2
2012-02-24 12:28 Piotr Karasinski Widgetset => Carbon
2012-02-24 12:29 Piotr Karasinski Tag Attached: Carbon
2012-02-24 12:29 Piotr Karasinski Tag Attached: TSaveDialog
2012-03-13 08:41 Zeljan Rikalo LazTarget => 1.2
2012-03-13 08:41 Zeljan Rikalo Status new => acknowledged
2012-03-13 08:41 Zeljan Rikalo Target Version => 1.2.0
2013-02-20 06:18 Jesus Reyes Assigned To => Jesus Reyes
2013-02-20 06:18 Jesus Reyes Status acknowledged => assigned
2013-02-20 07:07 Jesus Reyes Fixed in Revision => 40343
2013-02-20 07:07 Jesus Reyes Note Added: 0065775
2013-02-20 07:07 Jesus Reyes Status assigned => resolved
2013-02-20 07:07 Jesus Reyes Fixed in Version => 1.1 (SVN)
2013-02-20 07:07 Jesus Reyes Resolution open => fixed
2013-02-20 07:08 Jesus Reyes Note Edited: 0065775 View Revisions