View Issue Details

IDProjectCategoryView StatusLast Update
0021375LazarusCompilerpublic2012-02-26 15:07
ReporterJohn Shand Assigned ToZeljan Rikalo  
PrioritynormalSeveritytweakReproducibilityalways
Status closedResolutionfixed 
PlatformLinux x64 bitOSopensuse 
Summary0021375: compiler error in building lazarus latest build
Descriptionerror found:

Fatal: Compilation aborted
make[1]: *** [alllclunits.ppu] Error 1
make[1]: Leaving directory `/home/jshand/rpm/BUILD/lazarus-0.9.31/lazarus/lcl'
make: *** [lcl] Error 2
error: Bad exit status from /home/jshand/rpm/tmp/rpm-tmp.LBSpbX (%build)


RPM build errors:
    Bad exit status from /home/jshand/rpm/tmp/rpm-tmp.LBSpbX (%build)
Steps To Reproduce./create_lazarus_rpm /home/user/fpc
TagsNo tags attached.
Fixed in Revision
LazTarget-
Widgetset
Attached Files

Relationships

duplicate of 0021376 resolvedJesus Reyes compiler error 

Activities

John Shand

2012-02-26 00:35

reporter   ~0057088

this might be a lazarus compilation error instead of a fpc compilation error

John Shand

2012-02-26 02:10

reporter   ~0057089

dbgrids.pas(1991,31) Error: Incompatible types: got "Pointer" expected "AnsiString"
dbgrids.pas(3828,54) Error: Incompatible type for arg no. 1: Got "Pointer", expected "AnsiString"
dbgrids.pas(3843,20) Error: Incompatible types: got "Pointer" expected "AnsiString"
dbgrids.pas(3895,28) Error: Incompatible type for arg no. 1: Got "AnsiString", expected "Pointer"
dbgrids.pas(3949) Fatal: There were 4 errors compiling module, stopping
Fatal: Compilation aborted
make[1]: *** [alllclunits.ppu] Error 1
make[1]: Leaving directory `/home/jshand/rpm/BUILD/lazarus-0.9.31/lazarus/lcl'
make: *** [lcl] Error 2
error: Bad exit status from /home/jshand/rpm/tmp/rpm-tmp.VS6Q8e (%build)


RPM build errors:
    Bad exit status from /home/jshand/rpm/tmp/rpm-tmp.VS6Q8e (%build)

Cyrax

2012-02-26 10:53

reporter   ~0057093

I'm getting same errors. This started happening after FPC SVN trunk revision 20424.

Zeljan Rikalo

2012-02-26 15:07

developer   ~0057101

Resolved because it's duplicate.

Issue History

Date Modified Username Field Change
2012-02-26 00:33 John Shand New Issue
2012-02-26 00:35 John Shand Note Added: 0057088
2012-02-26 00:42 Jonas Maebe Project FPC => Lazarus
2012-02-26 02:10 John Shand Note Added: 0057089
2012-02-26 10:53 Cyrax Note Added: 0057093
2012-02-26 10:54 Zeljan Rikalo Relationship added duplicate of 0021376
2012-02-26 15:07 Zeljan Rikalo LazTarget => -
2012-02-26 15:07 Zeljan Rikalo Status new => resolved
2012-02-26 15:07 Zeljan Rikalo Resolution open => fixed
2012-02-26 15:07 Zeljan Rikalo Assigned To => Zeljan Rikalo
2012-02-26 15:07 Zeljan Rikalo Note Added: 0057101
2012-02-26 15:07 Zeljan Rikalo Status resolved => closed