View Issue Details

IDProjectCategoryView StatusLast Update
0021399FPCDatabasepublic2012-03-07 19:50
ReporterCyrax Assigned ToJoost van der Sluis  
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionno change required 
Summary0021399: Since SVN trunk revision 20424 Lazarus IDE can't be built due to changes in db.pas
DescriptionFor more information, see this bug report : http://bugs.freepascal.org/view.php?id=21376

Attached patch is one step to remedy this situation.
TagsNo tags attached.
Fixed in Revision
FPCOldBugId0
FPCTarget
Attached Files

Relationships

related to 0021376 resolvedJesus Reyes Lazarus compiler error 

Activities

2012-03-01 14:07

 

db.pas.patch (678 bytes)   
Index: packages/fcl-db/src/base/db.pas
===================================================================
--- packages/fcl-db/src/base/db.pas	(revision 20457)
+++ packages/fcl-db/src/base/db.pas	(working copy)
@@ -1614,6 +1614,7 @@
     property BlockReadSize: Integer read FBlockReadSize write SetBlockReadSize;
     property BOF: Boolean read FBOF;
     property Bookmark: TBookmark read GetBookmark write GotoBookmark;
+    property BookmarkStr: TBookmarkStr read GetBookmarkStr write SetBookmarkStr;
     property CanModify: Boolean read GetCanModify;
     property DataSource: TDataSource read GetDataSource;
     property DefaultFields: Boolean read FDefaultFields;
db.pas.patch (678 bytes)   

Marco van de Voort

2012-03-01 22:45

manager   ~0057198

No longer needed, Jesus fixed it a different way. (which is better than introducing bookmarkstr, a property that is already deprecated in Delphi for some versions)

Issue History

Date Modified Username Field Change
2012-03-01 14:07 Cyrax New Issue
2012-03-01 14:07 Cyrax Status new => assigned
2012-03-01 14:07 Cyrax Assigned To => Joost van der Sluis
2012-03-01 14:07 Cyrax File Added: db.pas.patch
2012-03-01 14:13 Vincent Snijders Relationship added related to 0021376
2012-03-01 22:45 Marco van de Voort Status assigned => resolved
2012-03-01 22:45 Marco van de Voort Resolution open => unable to reproduce
2012-03-01 22:45 Marco van de Voort Note Added: 0057198
2012-03-01 22:45 Marco van de Voort FPCOldBugId => 0
2012-03-01 22:45 Marco van de Voort Resolution unable to reproduce => no change required
2012-03-07 19:50 Cyrax Status resolved => closed