View Issue Details

IDProjectCategoryView StatusLast Update
0021417LazarusLCLpublic2012-03-11 13:10
ReporterMāris DarbonisAssigned ToPaul Ishenin 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.9.30.2Product Build 
Target VersionFixed in Version0.9.31 (SVN) 
Summary0021417: Radio group items get superfluous click events on form re-activation
DescriptionIf a radio group item is clicked, then deactivated programmatically (e.g. by a timer event), form deactivated and activated again (by alt-tab or clicking on window titles) then previously clicked radio item gets another click event just from the window gaining focus. Workaround in source; also happens on Lazarus-0.9.31-35701-fpc-2.6.0-20120304-win32 .
TagsNo tags attached.
Fixed in Revision35878
LazTarget-
WidgetsetWin32/Win64
Attached Files

Relationships

related to 0020510 resolvedLuiz Americo TRadiogroup.ItemIndex -1 does not work 

Activities

2012-03-04 13:19

 

radio_issue.zip (64,880 bytes)

Zeljan Rikalo

2012-03-06 08:27

developer   ~0057306

I cannot reproduce this with trunk lazarus (win32, gtk2 and qt).
You shuold test with trunk or daily snapshot and give feedback.
I think it's fixed in trunk

Māris Darbonis

2012-03-06 15:31

reporter   ~0057324

Hmm, I can reproduce it with today's 0.9.31 from http://svn.freepascal.org/svn/lazarus/trunk/ with FPC 2.6.0 on XP, and also Lazarus-0.9.31-35701-fpc-2.6.0-20120305-win64 snapshot on Windows 7 64bit, but only on Windows, cannot reproduce on Mint12 with GTK2, don't have QT at hand but I guess that would be OK too.

  The attached project is timing sensitive, you have to
- click on RadioButton2,
- wait until timer activates RadioButton1,
- select another window,
- select the demo window again.
At this point for me RadioButton2 is selected, but only until timer deactivates it, still, after that switching windows activates RadioButton2 again.

Māris Darbonis

2012-03-06 15:41

reporter   ~0057325

XP is Build 2600.xpsp.080413-2111 : Service Pack 3

Zeljan Rikalo

2012-03-07 13:40

developer   ~0057355

Reproduced under win7 64bit.

Paul Ishenin

2012-03-11 02:43

manager   ~0057482

Please test and close if ok.

Māris Darbonis

2012-03-11 13:10

reporter   ~0057489

Yes, it's fixed, thanks.

Issue History

Date Modified Username Field Change
2012-03-04 13:19 Māris Darbonis New Issue
2012-03-04 13:19 Māris Darbonis File Added: radio_issue.zip
2012-03-04 13:19 Māris Darbonis Widgetset => Win32/Win64
2012-03-06 04:36 Juha Manninen Relationship added related to 0020510
2012-03-06 08:27 Zeljan Rikalo LazTarget => -
2012-03-06 08:27 Zeljan Rikalo Note Added: 0057306
2012-03-06 08:27 Zeljan Rikalo Status new => feedback
2012-03-06 15:31 Māris Darbonis Note Added: 0057324
2012-03-06 15:41 Māris Darbonis Note Added: 0057325
2012-03-07 13:40 Zeljan Rikalo Note Added: 0057355
2012-03-07 13:40 Zeljan Rikalo Status feedback => confirmed
2012-03-08 01:02 Paul Ishenin Status confirmed => assigned
2012-03-08 01:02 Paul Ishenin Assigned To => Paul Ishenin
2012-03-11 02:43 Paul Ishenin Fixed in Revision => 35878
2012-03-11 02:43 Paul Ishenin Status assigned => resolved
2012-03-11 02:43 Paul Ishenin Fixed in Version => 0.9.31 (SVN)
2012-03-11 02:43 Paul Ishenin Resolution open => fixed
2012-03-11 02:43 Paul Ishenin Note Added: 0057482
2012-03-11 13:10 Māris Darbonis Status resolved => closed
2012-03-11 13:10 Māris Darbonis Note Added: 0057489