View Issue Details

IDProjectCategoryView StatusLast Update
0021421LazarusIDEpublic2012-05-07 20:39
ReporterfpbtAssigned ToMartin Friebe 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
PlatformOSWindowsOS Version
Product VersionProduct Build 
Target VersionFixed in Version0.9.31 (SVN) 
Summary0021421: Expanding and collapsing code
DescriptionExpanding and collapsing code not correctly on some combinations.
TagsNo tags attached.
Fixed in Revision35612
LazTarget0.99.0
WidgetsetWin32/Win64
Attached Files

Activities

2012-03-05 19:19

 

test_01_02.png (13,797 bytes)
test_01_02.png (13,797 bytes)

Martin Friebe

2012-03-05 20:42

manager   ~0057298

Yes indeed, the issue is present in current released (including 0.9.30.4) versions.

Nested "repeat" block, can under certain circumstances do this.

The issue was fixed in 0.9.31:
Date: 27 February 2012 19:42:05
Message:SynPasSyn: fixed smart closing of repeat nodes
Modified : /trunk/components/synedit/synhighlighterpas.pp

You can find and remove the following line:
    SmartCloseBeginEndBlocks(cfbtRepeat);

fpbt

2012-05-07 20:39

reporter   ~0059365

tested
close

Issue History

Date Modified Username Field Change
2012-03-05 19:19 fpbt New Issue
2012-03-05 19:19 fpbt File Added: test_01_02.png
2012-03-05 19:19 fpbt Widgetset => Win32/Win64
2012-03-05 20:42 Martin Friebe Fixed in Revision => 35612
2012-03-05 20:42 Martin Friebe LazTarget => 0.99.0
2012-03-05 20:42 Martin Friebe Status new => resolved
2012-03-05 20:42 Martin Friebe Fixed in Version => 0.9.31 (SVN)
2012-03-05 20:42 Martin Friebe Resolution open => fixed
2012-03-05 20:42 Martin Friebe Assigned To => Martin Friebe
2012-03-05 20:42 Martin Friebe Note Added: 0057298
2012-03-05 20:42 Martin Friebe Target Version => 0.99.0
2012-05-07 20:39 fpbt Status resolved => closed
2012-05-07 20:39 fpbt Note Added: 0059365