View Issue Details

IDProjectCategoryView StatusLast Update
0021476LazarusDatabasepublic2012-03-16 10:30
ReporterAnderson BAssigned ToJesus Reyes 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version0.9.31 (SVN)Product Build 
Target Version1.2.0Fixed in Version0.9.31 (SVN) 
Summary0021476: TSQLQUERY + DBGrid + MultiSelect = don't work
DescriptionTSQLQUERY and DBGrid MultiSelect option are not working.

I have found this http://bugs.freepascal.org/view.php?id=13565
Maybe is the same BookMarks problem.

Have tested with TDBF and it works fine. So I think DBGrid is working will.

Additional InformationI'm using TSQLQUERY with TSQLite3Connection.
And Lazarus-0.9.31-35878-fpc-2.6.1-20120311-win32
TagsNo tags attached.
Fixed in Revision36080
LazTarget1.2
WidgetsetWin32/Win64
Attached Files

Activities

2012-03-15 02:06

 

DBGridMultiSel.7z (246,262 bytes)

Anderson B

2012-03-15 02:07

reporter   ~0057659

Attached a sample program

Anderson B

2012-03-15 03:20

reporter   ~0057660

TSqlite3Dataset works great too.
Almost sure that the problem is with TSQLQUERY

Issue History

Date Modified Username Field Change
2012-03-13 18:38 Anderson B New Issue
2012-03-13 18:38 Anderson B Widgetset => Win32/Win64
2012-03-13 18:45 Vincent Snijders LazTarget => -
2012-03-13 18:45 Vincent Snijders Product Version 0.9.30.4RC1 => 0.9.31 (SVN)
2012-03-14 07:46 Vincent Snijders LazTarget - => 1.2
2012-03-14 07:46 Vincent Snijders Assigned To => Jesus Reyes
2012-03-14 07:46 Vincent Snijders Status new => assigned
2012-03-14 07:46 Vincent Snijders Target Version => 1.2.0
2012-03-15 02:06 Anderson B File Added: DBGridMultiSel.7z
2012-03-15 02:07 Anderson B Note Added: 0057659
2012-03-15 03:20 Anderson B Note Added: 0057660
2012-03-16 10:29 Jesus Reyes Fixed in Revision => 36080
2012-03-16 10:29 Jesus Reyes Status assigned => resolved
2012-03-16 10:29 Jesus Reyes Fixed in Version => 0.9.31 (SVN)
2012-03-16 10:29 Jesus Reyes Resolution open => fixed