View Issue Details

IDProjectCategoryView StatusLast Update
0021534LazarusCustom Drawnpublic2012-03-23 07:22
ReporterTakeda MatsukiAssigned ToFelipe Monteiro de Carvalho 
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
Product Version0.9.31 (SVN)Product Build 
Target VersionFixed in Version0.9.31 (SVN) 
Summary0021534: Forward declaration not solved "TCDWidgetset.GetKeyState" for arm-linux (android)
DescriptionI use Lazarus svn 36227
FPC 2.7.1 svn 20549
Windows 7 Ultimate SP1 x64

All requirements to build Android already fulfill by me.
Also I already set "OS_TARGET = Linux", "CPU_TARGET=arm".. Widgetset already set to "CustomDrawn".

Additional InformationI saw, might it caused by rev 36189, since the parenthesis was opened for GetKeyState ( http://svn.freepascal.org/cgi-bin/viewvc.cgi/trunk/lcl/interfaces/customdrawn/customdrawnwinapih.inc?root=lazarus&r1=36189&r2=36188&pathrev=36189 ).

If I close the parenthesis back like before 36189, then I successful to compile it.


Regards,
Takeda

TagsNo tags attached.
Fixed in Revision36241
LazTarget-
WidgetsetCustomDrawn
Attached Files

Activities

2012-03-23 00:01

 

Laz LCL-Customdrawn Error.jpg (402,928 bytes)

Issue History

Date Modified Username Field Change
2012-03-23 00:01 Takeda Matsuki New Issue
2012-03-23 00:01 Takeda Matsuki File Added: Laz LCL-Customdrawn Error.jpg
2012-03-23 00:01 Takeda Matsuki Widgetset => CustomDrawn
2012-03-23 07:16 Felipe Monteiro de Carvalho Status new => assigned
2012-03-23 07:16 Felipe Monteiro de Carvalho Assigned To => Felipe Monteiro de Carvalho
2012-03-23 07:22 Felipe Monteiro de Carvalho Fixed in Revision => 36241
2012-03-23 07:22 Felipe Monteiro de Carvalho LazTarget => -
2012-03-23 07:22 Felipe Monteiro de Carvalho Status assigned => resolved
2012-03-23 07:22 Felipe Monteiro de Carvalho Fixed in Version => 0.9.31 (SVN)
2012-03-23 07:22 Felipe Monteiro de Carvalho Resolution open => fixed