View Issue Details

IDProjectCategoryView StatusLast Update
0021557LazarusLCLpublic2020-03-31 11:17
Reportergoldenfox Assigned ToJuha Manninen  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionnot fixable 
Product Version0.9.31 (SVN) 
Summary0021557: TStatusbar some characters were overlapped by the resize image
DescriptionPlease see attached sample source and screenshot.
Additional InformationLazarus 0.9.31 SVN 36303
Windows 7 Ultimate with aero desktop
TagsNo tags attached.
Fixed in Revision
LazTarget-
WidgetsetWin32/Win64
Attached Files

Activities

2012-03-26 04:56

 

tstatusbar.7z (60,109 bytes)

2012-03-26 04:57

 

Capture.PNG (16,039 bytes)   
Capture.PNG (16,039 bytes)   

Bart Broersma

2012-03-26 10:39

developer   ~0058043

Last edited: 2012-03-26 10:40

Please do not use 7-zip as compression, since it is not cross-platform supported.
Use regular zip instead.

goldenfox

2012-03-26 11:10

reporter   ~0058044

Thanks for the hint. I'll update the compressed file.

2012-03-26 11:12

 

tstatusbar.zip (128,584 bytes)

Paul Ishenin

2012-03-27 04:59

manager   ~0058091

I see this behavior in delphi too. Probably windows does not care if size grip overlaps the text.

Vincent Snijders

2012-04-17 11:30

manager   ~0058671

Not fixable then?

Zeljan Rikalo

2012-04-17 12:26

developer   ~0058674

I think it's not bug, that's windows behaviour - sizegrip isn't transparent.

Mark Morgan Lloyd

2012-04-18 13:16

reporter   ~0058710

Last edited: 2012-04-18 13:54

Always been like that in Delphi, affects Lazarus GTK but possibly not Qt.

Where this is important, for example where a serial comms program has coloured panels representing signal state, I usually end up with nested panels and an icon overlay. However this obviously wouldn't track the "look and feel" of the current widget set.

On Win-32, there's an undocumented hack to tell a form that it's to treat a corner icon as a resize grip:

procedure TEditorForm.GripMouseDown(Sender: TObject; Button: TMouseButton;
                                                Shift: TShiftState; X, Y: Integer);

(* Magic code from adr@cix who notes "The value 8 is a complete mystery *)
(* to me, I can't find any documentation on it. I found it by *)
(* experimentation." *)

begin
  ReleaseCapture;
  Perform(WM_SYSCOMMAND, SC_SIZE + 8, 0)
end (* TEditorForm.GripMouseDown *) ;

Zeljan Rikalo

2012-04-18 20:53

developer   ~0058725

Under qt it's more elegant:
http://doc.qt.nokia.com/4.7/qstatusbar.html#sizeGripEnabled-prop
QStatusBar already contains sizegrip which can be disabled (hidden).
Also, you can reach sizegrip by iterating QStatusBar children because it's QSizeGrip class and do whatever with it.
Also, QSizeGrip can be added to any form without QStatusBar.

Juha Manninen

2020-03-31 11:17

developer   ~0121792

Widgetset feature. Resolving as "not fixable".

Issue History

Date Modified Username Field Change
2012-03-26 04:56 goldenfox New Issue
2012-03-26 04:56 goldenfox File Added: tstatusbar.7z
2012-03-26 04:56 goldenfox Widgetset => Win32/Win64
2012-03-26 04:57 goldenfox File Added: Capture.PNG
2012-03-26 10:39 Bart Broersma LazTarget => -
2012-03-26 10:39 Bart Broersma Note Added: 0058043
2012-03-26 10:39 Bart Broersma Status new => feedback
2012-03-26 10:40 Bart Broersma Note Edited: 0058043
2012-03-26 11:10 goldenfox Note Added: 0058044
2012-03-26 11:12 goldenfox File Added: tstatusbar.zip
2012-03-26 21:54 Bart Broersma Status feedback => new
2012-03-27 04:59 Paul Ishenin Note Added: 0058091
2012-04-17 11:30 Vincent Snijders Note Added: 0058671
2012-04-17 12:26 Zeljan Rikalo Note Added: 0058674
2012-04-18 13:16 Mark Morgan Lloyd Note Added: 0058710
2012-04-18 13:54 Mark Morgan Lloyd Note Edited: 0058710
2012-04-18 20:53 Zeljan Rikalo Note Added: 0058725
2020-03-31 11:17 Juha Manninen Assigned To => Juha Manninen
2020-03-31 11:17 Juha Manninen Status new => resolved
2020-03-31 11:17 Juha Manninen Resolution open => not fixable
2020-03-31 11:17 Juha Manninen Widgetset Win32/Win64 => Win32/Win64
2020-03-31 11:17 Juha Manninen Note Added: 0121792