View Issue Details

IDProjectCategoryView StatusLast Update
0021644LazarusLCLpublic2012-04-08 17:18
ReporterJD Assigned ToJuha Manninen  
PrioritynormalSeverityblockReproducibilityalways
Status resolvedResolutionfixed 
Product Version0.9.31 (SVN) 
Summary0021644: Testing calculator dialog locks up the Lazarus IDE
DescriptionHi there everyone,

When I put the Calculator Dialog on a form and then left click on it and select 'Test dialog', a modal calculator window is displayed.

But there is no way to attempt a calculation or worse to close the modal calculator window. One can only close Lazarus via the Windows Task Manager.

Behaviour was observed on Windows Vista.

I'm using Lazarus 0.9.31 svn 36335/fpc 2.6.0/i386-win32
TagsNo tags attached.
Fixed in Revisionr36661
LazTarget0.99.0
WidgetsetWin32/Win64, QT
Attached Files

Relationships

has duplicate 0022162 resolvedJuha Manninen TCalendarDialog 

Activities

Bart Broersma

2012-04-04 16:31

developer   ~0058292

Confirmed with Lazarus 1.1 r36560 FPC 2.6.0 i386-win32-win32/win64 (Win7 64 bit, 32-bit Lazarus)

Juha Manninen

2012-04-08 08:44

developer   ~0058403

Last edited: 2012-04-08 09:06

The exact same TCalculatorDialog.Execute is called at run time and at design time when testing the dialog.
At run time it works but at design time no mouse input is accepted.
The problem happens on Windows and on Linux with QT bindings, although on Linux the window manager lets you close the calc window.

Keyboard input is possible with QT but not on Windows. On Windows it halts the whole Lazarus and is equivalent to a crash bug.

For some reason it works correctly with GTK2 bindings!

If this cannot be fixed properly then the "Test dialog" feature should be disabled on Windows platform.

Bart Broersma

2012-04-08 09:28

developer   ~0058404

Actually, why does it have a "Test dialog" feature anyway?
Most dialogs do not have this.
Preferrably however, the root cause of this bug should be fixed.

Juha Manninen

2012-04-08 17:18

developer   ~0058409

Solved with Martin's help.
Please test.

Bart, all dialogs in palette seem to have a test feature now. It is good, gives more reason to use those graphical icons for non-graphical components.

Issue History

Date Modified Username Field Change
2012-04-04 13:27 JD New Issue
2012-04-04 13:27 JD Widgetset => Win32/Win64
2012-04-04 16:20 Bart Broersma LazTarget => -
2012-04-04 16:20 Bart Broersma Status new => confirmed
2012-04-04 16:31 Bart Broersma Note Added: 0058292
2012-04-08 08:38 Juha Manninen LazTarget - => 0.99.0
2012-04-08 08:38 Juha Manninen Widgetset Win32/Win64 => Win32/Win64, QT
2012-04-08 08:38 Juha Manninen Severity minor => block
2012-04-08 08:38 Juha Manninen Reproducibility have not tried => always
2012-04-08 08:44 Juha Manninen Note Added: 0058403
2012-04-08 09:06 Juha Manninen Note Edited: 0058403
2012-04-08 09:28 Bart Broersma Note Added: 0058404
2012-04-08 17:12 Juha Manninen Status confirmed => assigned
2012-04-08 17:12 Juha Manninen Assigned To => Juha Manninen
2012-04-08 17:18 Juha Manninen Fixed in Revision => r36661
2012-04-08 17:18 Juha Manninen Status assigned => resolved
2012-04-08 17:18 Juha Manninen Resolution open => fixed
2012-04-08 17:18 Juha Manninen Note Added: 0058409
2012-06-01 20:10 Juha Manninen Relationship added has duplicate 0022162