View Issue Details

IDProjectCategoryView StatusLast Update
0021713LazarusLCLpublic2012-04-12 10:33
ReporterVojtech Cihak Assigned ToZeljan Rikalo  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.9.31 (SVN) 
Summary0021713: MouseCapture behaviour
DescriptionSee attached simple project.
First button creates CustomListBox.
Second button set MouseCapture to created CustomListBox.
It works well with Qt but mouse is not captured on GTK2 and MouseDown nor MouseMove events are not caught outside of component.
(The same with CustomMemo.)

I selected as GTK2 issue because IMO Qt behaves correctly.
Additional InformationLazarus 1.1 r36711M FPC 2.5.1 x86_64-linux-qt
TagsNo tags attached.
Fixed in Revision36734
LazTarget-
WidgetsetGTK 2
Attached Files

Activities

2012-04-11 21:21

 

LB_MouseCapture.zip (6,603 bytes)

Zeljan Rikalo

2012-04-12 08:34

developer   ~0058525

Please test and close if ok.

Vojtech Cihak

2012-04-12 10:33

reporter   ~0058528

Thanks, works with 26734

Issue History

Date Modified Username Field Change
2012-04-11 21:21 Vojtech Cihak New Issue
2012-04-11 21:21 Vojtech Cihak File Added: LB_MouseCapture.zip
2012-04-11 21:21 Vojtech Cihak Widgetset => GTK 2
2012-04-12 08:26 Zeljan Rikalo Status new => assigned
2012-04-12 08:26 Zeljan Rikalo Assigned To => Zeljan Rikalo
2012-04-12 08:34 Zeljan Rikalo Fixed in Revision => 36734
2012-04-12 08:34 Zeljan Rikalo LazTarget => -
2012-04-12 08:34 Zeljan Rikalo Status assigned => resolved
2012-04-12 08:34 Zeljan Rikalo Resolution open => fixed
2012-04-12 08:34 Zeljan Rikalo Note Added: 0058525
2012-04-12 10:33 Vojtech Cihak Status resolved => closed
2012-04-12 10:33 Vojtech Cihak Note Added: 0058528