View Issue Details

IDProjectCategoryView StatusLast Update
0021724LazarusWidgetsetpublic2012-04-16 13:28
ReportercobinesAssigned ToPaul Ishenin 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformWin32OSWindows XPOS VersionSP3
Product Version0.9.31 (SVN)Product Build31847 
Target VersionFixed in Version1.1 (SVN) 
Summary0021724: Minimizing and restoring maximized form changes size and position of aligned controls
DescriptionIn the example project there is a Form2 which has a Memo that has Align=alClient.

1. Run example, press "Show second form" to show Form2. Memo should spread over all Form2.
2. Maximize Form2, minimize Form2, restore Form2. Now Memo does not spread over all Form2 but sits in the left corner.

The bug doesn't exist if Form2 is main form of the application. In the example it is a secondary form on purpose.
The bug doesn't happen with Lazarus 0.9.30.5.
TagsNo tags attached.
Fixed in Revision36804
LazTarget-
WidgetsetWin32/Win64
Attached Files

Relationships

related to 0021119 confirmedZeljan Rikalo When a form is started as wsMaximized height and width report design time values 

Activities

2012-04-12 11:19

 

minrestore_maximized_form.zip (2,618 bytes)

Paul Ishenin

2012-04-16 05:05

manager   ~0058638

I can reproduce the bug if this form is the main form

Paul Ishenin

2012-04-16 05:36

manager   ~0058639

Please test and close if ok.

Since the fix contains significant changes on sizing hevavior please also check whether it does not harm something else.

cobines

2012-04-16 13:28

reporter   ~0058650

I think it is OK. The bug is gone, I ran a few other test projects and didn't notice any regressions.

Issue History

Date Modified Username Field Change
2012-04-12 11:19 cobines New Issue
2012-04-12 11:19 cobines File Added: minrestore_maximized_form.zip
2012-04-12 11:19 cobines Widgetset => Win32/Win64
2012-04-12 13:21 Zeljan Rikalo Relationship added related to 0021119
2012-04-12 13:21 Zeljan Rikalo Status new => assigned
2012-04-12 13:21 Zeljan Rikalo Assigned To => Paul Ishenin
2012-04-16 05:05 Paul Ishenin Note Added: 0058638
2012-04-16 05:36 Paul Ishenin Fixed in Revision => 36804
2012-04-16 05:36 Paul Ishenin LazTarget => -
2012-04-16 05:36 Paul Ishenin Status assigned => resolved
2012-04-16 05:36 Paul Ishenin Fixed in Version => 1.1 (SVN)
2012-04-16 05:36 Paul Ishenin Resolution open => fixed
2012-04-16 05:36 Paul Ishenin Note Added: 0058639
2012-04-16 13:28 cobines Status resolved => closed
2012-04-16 13:28 cobines Note Added: 0058650