View Issue Details

IDProjectCategoryView StatusLast Update
0021773LazarusIDEpublic2012-04-15 05:53
ReporterStephano Assigned ToJuha Manninen  
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version0.9.31 (SVN) 
Summary0021773: Abstract method called error upon launching the IDE
Description"Abstract method called.

Press OK to ignore and risk data corruption.
Press Cancel to kill the program."

Lazarus 1.1 r36776 FPC 2.6.1 i386-linux-gtk 2

Rev r36738 is OK
TagsNo tags attached.
Fixed in Revisionr36779
LazTarget-
Widgetset
Attached Files

Activities

Juha Manninen

2012-04-14 20:09

developer   ~0058597

Can you get a backtrace of it?
It can be caused by a package. Could you test which package.

Juha Manninen

2012-04-14 20:35

developer   ~0058598

It was a missing TGtk2WidgetSet.SetDesigning method. I added it.
Please test.

Issue History

Date Modified Username Field Change
2012-04-14 18:45 Stephano New Issue
2012-04-14 20:09 Juha Manninen LazTarget => -
2012-04-14 20:09 Juha Manninen Note Added: 0058597
2012-04-14 20:09 Juha Manninen Status new => feedback
2012-04-14 20:31 Juha Manninen Status feedback => assigned
2012-04-14 20:31 Juha Manninen Assigned To => Juha Manninen
2012-04-14 20:35 Juha Manninen Fixed in Revision => r36779
2012-04-14 20:35 Juha Manninen Status assigned => resolved
2012-04-14 20:35 Juha Manninen Resolution open => fixed
2012-04-14 20:35 Juha Manninen Note Added: 0058598
2012-04-15 05:53 Stephano Status resolved => closed