View Issue Details

IDProjectCategoryView StatusLast Update
0021936LazarusWidgetsetpublic2019-04-22 17:33
ReporterMartin Friebe Assigned ToJuha Manninen  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionduplicate 
Product Version1.1 (SVN) 
Summary0021936: GTK2: Broken Standard Hint - blocks entire app
DescriptionThe normal hint on gtk2 can be tricked into faulty behaviour.
However this is only possible (or I have only found that way) with TIPHtml.


To reproduce (TIProDesign must be installed, for HTML hints):

- Hover over some source, so you get the html hint.
- Move the mouse over the hint
- The hint will have at least a link to where the identifier is defined.
   Hover over that link.
   A 2nd hint (a normal hint will display.) Something is forcing that
hint open as long as the mouse is over the link
- While the 2nd link is open, use the right mouse, to pop up the context
menu
  now all three are open: html hint, normal link, context menu
- Move mouse outside the IDE (while popup open) and click desktop or
none-IDE win

The context menu closes. Both hint stay open.

Try to return to lazarus. The normal hint is kept there and blocks all else.

Works fine on Windows
Of course IPro can be fixed to close the normal hint on context menu.
But that is not the point. The hint should not block the IDE
TagsNo tags attached.
Fixed in Revision
LazTarget-
WidgetsetGTK 2
Attached Files

Relationships

duplicate of 0022081 new Source editor Hint not hided sometimes and block screen 

Activities

Martin Friebe

2012-05-23 12:05

manager   ~0059882

In order to still reproduce, comment out the timer-based checks for mouse-movement, introduced in r37378

Ihor Lavrynyuk

2012-05-23 16:47

reporter   ~0059885

and if selected all text in unit then speedily click green play(run > ) button - and move and stop mouse on the free space(but selected - blue) in unit - we have big hint with all text from unit

Martin Friebe

2012-05-23 17:45

manager   ~0059886

@Ihor: This is already noted, in another bug report that you made.

Juha Manninen

2013-05-05 11:36

developer   ~0067463

Resolving as duplicate.

Issue History

Date Modified Username Field Change
2012-05-03 21:31 Martin Friebe New Issue
2012-05-03 21:31 Martin Friebe LazTarget => -
2012-05-03 21:31 Martin Friebe Widgetset => GTK 2
2012-05-19 15:23 Martin Friebe Relationship added duplicate of 0022081
2012-05-23 12:05 Martin Friebe Note Added: 0059882
2012-05-23 16:47 Ihor Lavrynyuk Note Added: 0059885
2012-05-23 17:45 Martin Friebe Note Added: 0059886
2013-05-05 11:36 Juha Manninen Note Added: 0067463
2013-05-05 11:36 Juha Manninen Status new => resolved
2013-05-05 11:36 Juha Manninen Resolution open => duplicate
2013-05-05 11:36 Juha Manninen Assigned To => Juha Manninen
2019-04-22 17:33 Martin Friebe Status resolved => closed