View Issue Details

IDProjectCategoryView StatusLast Update
0021998LazarusLCLpublic2019-08-07 20:05
ReporterPaul van HeldenAssigned ToStephano 
PrioritynormalSeveritytrivialReproducibilityalways
Status resolvedResolutionunable to reproduce 
Product Version1.1 (SVN)Product Build 
Target VersionFixed in Version 
Summary0021998: TSpeedButton in check mode still has black background when down (WinCE)
DescriptionI've been commenting out line 2082 every time I install a new Lazarus for the last 18 months. This is only a problem on WinCE. FillWithDottedBrush just paints it black (?!)
Additional InformationTo reproduce just put a TSpeedButton on a form, set GroupIndex:=1 so that it acts like a radio button (toggles) and set Down:=True. Perhaps also Flat:=True; It will display with a black background on WinCE
Tagswince
Fixed in Revision
LazTarget-
WidgetsetWinCE
Attached Files

Relationships

related to 0026748 closedFelipe Monteiro de Carvalho Patches [Patch] Improved CreateBrushIndirect workaround 

Activities

Paul van Helden

2012-05-10 16:14

reporter   ~0059469

That would be line 2082 of Themes.pas

Andrew G. Khodotov

2014-09-19 19:19

reporter   ~0077434

I think patch from http://bugs.freepascal.org/view.php?id=26748 can solve this problem.

Stephano

2015-02-07 14:23

developer   ~0080840

Cannot reproduce. Probably resolved by 0026748.

Issue History

Date Modified Username Field Change
2012-05-09 21:27 Paul van Helden New Issue
2012-05-09 21:27 Paul van Helden Widgetset => WinCE
2012-05-10 16:14 Paul van Helden Note Added: 0059469
2014-09-19 19:19 Andrew G. Khodotov Note Added: 0077434
2014-09-19 23:57 Juha Manninen Relationship added related to 0026748
2015-02-06 18:05 Juha Manninen Assigned To => Stephano
2015-02-06 18:05 Juha Manninen Status new => assigned
2015-02-07 14:23 Stephano Note Added: 0080840
2015-02-07 14:23 Stephano LazTarget => -
2015-02-07 14:23 Stephano Status assigned => resolved
2015-02-07 14:23 Stephano Resolution open => unable to reproduce
2019-08-07 20:05 LacaK Tag Attached: wince