View Issue Details

IDProjectCategoryView StatusLast Update
0022028LazarusLazReportpublic2012-06-07 22:19
ReporteralexPAssigned ToJesus Reyes 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Platformx64 fpc2.6.0OSlinux fedora 16 x64OS VersionLazarus svn
Product Version1.1 (SVN)Product Build32272M 
Target VersionFixed in Version1.1 (SVN) 
Summary0022028: Stresh Error in line when the text is long on one of the fields
Descriptionenter a field with characters that exceed the limit line, see the attached example is a photo with name bug.png
TagsNo tags attached.
Fixed in Revision37415
LazTarget-
WidgetsetGTK 2
Attached Files

Activities

2012-05-14 02:23

 

bug.zip (18,537 bytes)

Jesus Reyes

2012-05-19 21:25

developer   ~0059768

This is the example, and what is the data that triggers the problem?

alexP

2012-05-23 03:47

reporter   ~0059873

yes, you can see how it looks in the photo (bug.png).

able to generate the error you must enter more characters than forcing a line under the text to line however do not stretch the field accompanying the text. A few months ago this problem did not not know exactly en began dating.

alexP

2012-05-31 01:21

reporter   ~0060082

sorry friends has not yet been resolved, I created a new project that this defect is clearer just send run and see what the result looks like the photo bug.pgn

2012-05-31 01:21

 

bug2.zip (21,520 bytes)

Jesus Reyes

2012-05-31 08:34

developer   ~0060084

sorry, it is resolved. According to your bug2 project you didn't set the second horizontal line object as "stretched", if it's not stretched it will not move following the band height increase. This is probably my fault as I forgot to give that advice on resolving this report the first time.

Anyway, after trying your sample I found a bug that made "stretchable" horizontal line objects to accumulate position instead of being reset on each record. I fixed this problem in r37467

2012-05-31 12:44

 

video.ogg (1,925,130 bytes)

alexP

2012-05-31 12:48

reporter   ~0060089

Sorry again, but I had to re-open again

In reports that worked in version 0.9 today at 01.01 began to defect and as you can see in the video fields marked as stretched and still the first line does not stretch.

If you want to close it again and again reabrirei not put the problem exists.

Jesus Reyes

2012-06-01 01:23

developer   ~0060096

Your video doesn't show if the LINE OBJECT has the "stretched" property ON. If it is the same project as the one you attached to this report (bug2.zip) then I know that LINE OBJECT doesn't have stretched property ON.

Just for the sake of clarification, on "Master Data" band you have two lines objects, first one should draw a fixed line at start of each record and is longer than the second one, the second line, I assume, should be drawn "at the end" of EACH RECORD. If that is right, then this second line object need to have the STRETCHED property ON so it will move according to the grown of the band. If stretched property is off for this line object it means it will be fixed, just like it appear in your video.

about "if you want to close it again and again reabrirei not put the problem exists."
 
I don't quite understand it, it seems to say that it doesn't matter the times I resolve this report you will reopen again as long as you see it's not fixed?, if that is the meaning, then you are right, you can keep it open as long as the bug is not fixed.

But you have to demonstrate the bug exists and as long as you can't do it, and if I cannot reproduce it here, why it should be kept open?

alexP

2012-06-03 02:43

reporter   ~0060201

the third click displays the popup menu with the property line stretched active in this (14 seconds of video).

Sorry if I expressed it poorly in the previous message.

I want to show is that it stretches in the first line put the cell no accompanying text, from the second line follows generally so I put the line that is easier to visualize

Jesus Reyes

2012-06-03 20:06

developer   ~0060236

If you look careful to the video, the line objects never gets selected, check the designer status bar to see what object is selected, at second 13 it shows "MasterData1:Master data" but it never shows the line object.

alexP

2012-06-06 21:55

reporter   ~0060320

sorry, now that I realized what was really disturbing is the line I think it should monitor the cell (down along with it), but really stretching the cell is good and so you can close the bug.

Issue History

Date Modified Username Field Change
2012-05-14 02:23 alexP New Issue
2012-05-14 02:23 alexP File Added: bug.zip
2012-05-14 02:23 alexP Widgetset => GTK 2
2012-05-14 08:08 Zeljan Rikalo Status new => assigned
2012-05-14 08:08 Zeljan Rikalo Assigned To => Jesus Reyes
2012-05-19 21:25 Jesus Reyes LazTarget => -
2012-05-19 21:25 Jesus Reyes Note Added: 0059768
2012-05-19 21:25 Jesus Reyes Status assigned => feedback
2012-05-23 03:47 alexP Note Added: 0059873
2012-05-25 06:37 Jesus Reyes Fixed in Revision => 37415
2012-05-25 06:37 Jesus Reyes Status feedback => resolved
2012-05-25 06:37 Jesus Reyes Fixed in Version => 1.1 (SVN)
2012-05-25 06:37 Jesus Reyes Resolution open => fixed
2012-05-31 01:21 alexP Status resolved => assigned
2012-05-31 01:21 alexP Resolution fixed => reopened
2012-05-31 01:21 alexP Note Added: 0060082
2012-05-31 01:21 alexP File Added: bug2.zip
2012-05-31 08:34 Jesus Reyes Status assigned => resolved
2012-05-31 08:34 Jesus Reyes Resolution reopened => fixed
2012-05-31 08:34 Jesus Reyes Note Added: 0060084
2012-05-31 12:44 alexP File Added: video.ogg
2012-05-31 12:48 alexP Status resolved => assigned
2012-05-31 12:48 alexP Resolution fixed => reopened
2012-05-31 12:48 alexP Note Added: 0060089
2012-06-01 01:23 Jesus Reyes Note Added: 0060096
2012-06-01 01:23 Jesus Reyes Status assigned => feedback
2012-06-03 02:43 alexP Note Added: 0060201
2012-06-03 20:06 Jesus Reyes Note Added: 0060236
2012-06-06 21:55 alexP Note Added: 0060320
2012-06-07 22:19 Jesus Reyes Status feedback => resolved
2012-06-07 22:19 Jesus Reyes Resolution reopened => fixed