View Issue Details

IDProjectCategoryView StatusLast Update
0022130FPCFCLpublic2014-03-06 10:23
ReporterBenito van der Zander Assigned ToMichael Van Canneyt  
PrioritynormalSeverityfeatureReproducibilityalways
Status closedResolutionfixed 
Platformamd64OSDebian 
Product Version2.6.0 
Target Version2.6.2Fixed in Version3.0.0 
Summary0022130: lazy initialization of fcl-net.netdb
DescriptionCurrently the netdb unit initializes various things in its initialization section.
It would be better, if this initialization was done at the first usage of one its functions, because the current way:
1. doesn't work, if the program is started before the config files are created.
   And since the gnome NetworkManager writes the /etc/resolv.conf a few seconds after startup, the initialization fails for all programs set to autostart.
2. screws up smart linking
TagsNo tags attached.
Fixed in Revision23336
FPCOldBugId
FPCTarget
Attached Files

Relationships

related to 0020484 closedMichael Van Canneyt NetDB unable to resolve DNS when application was launched without network 

Activities

Marco van de Voort

2012-05-25 13:42

manager   ~0059940

The first is a known bug, see related issue.

Michael Van Canneyt

2013-01-07 12:27

administrator   ~0064712

There was a bug in the checkresolvefile function.

Issue History

Date Modified Username Field Change
2012-05-25 12:58 Benito van der Zander New Issue
2012-05-25 13:41 Marco van de Voort Relationship added related to 0020484
2012-05-25 13:42 Marco van de Voort Note Added: 0059940
2013-01-07 12:27 Michael Van Canneyt Fixed in Revision => 23336
2013-01-07 12:27 Michael Van Canneyt Status new => resolved
2013-01-07 12:27 Michael Van Canneyt Fixed in Version => 2.7.1
2013-01-07 12:27 Michael Van Canneyt Resolution open => fixed
2013-01-07 12:27 Michael Van Canneyt Assigned To => Michael Van Canneyt
2013-01-07 12:27 Michael Van Canneyt Note Added: 0064712
2013-01-07 12:27 Michael Van Canneyt Target Version => 2.6.2
2014-03-06 10:23 Michael Van Canneyt Status resolved => closed