View Issue Details

IDProjectCategoryView StatusLast Update
0022141PatchesLCLpublic2012-05-30 21:32
ReporterLagunov Aleksey Assigned ToJesus Reyes  
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
PlatformallOSall 
Product Version1.1 (SVN) 
Fixed in Version1.1 (SVN) 
Summary0022141: Patch for LazReport - continue work on DialogControls...
Descriptioneng:
1. Implemented drawing on TfrPageDialog page for CheckBox and RadioButton components
2. Fixed double parameters querying problem for two-pass report
3. Fixed error when creating several TfrPageDialog pages
4. Show report copy in report editor mode - don't lose original report settings (Active state of datasets etc.)
5. SaveToXMLStream method is implemented for TfrReport - saving the report to arbitrary stream in xml format
6. Report page being edited get added to TfrObjectInspector object list
7. Implemented Database property editor for TLRSQLQuery
8. Removed TfrDesignerForm.FileModified variable. Only TfrReportDesigner.Modified variable variable is used as modification flag.
9. TfrReportDesigner.Modified changed from variable to property
10. Display message about changed state in statusbar when changing any object in report editor
11. Use TAction for Save and SaveAs commands - centralized commands management. Save command is available only when report is changed.
12. Fixed problem with saving of TfrObject.Visible property - it was saved as number and read as boolean
13. Reworked parameters handling for LRZQuery
14. Added license information to packages
15. Properly set caption for TfrPageDialog dialog
16. Fixed script for TfrPageDialog - property values were not set
17. Implemented TlrDBLookupComboBox component
18. Fixed modules text duplication
19. Fixed saving frPage.PageType property
20. Fixed saving frPage.Script property
21. Fix: selection on report components panel was not reset after component insertion to the report
22. Fixed calculation of aggregate values
23. Fixed resizing of TfrPageDialog dialog after changing of default printer
24. Scripts of TfrPageDialog are executed before report printing
25. Fixed values ​​sum in scripts if the summed field in the database = null
26. Minor bugfixes ...

rus:
1. Для CheckBox и RadioButton реализована отрисовка компонентов на странице TfrPageDialog
2. Исправлена ошибка двойного запроса параметров при двух-проходном отчёте
3. Исправлена ошибка создания нескольких страниц TfrPageDialog
4. В режиме редактора отчёта для показа отчёта используется его копия - не портятся первоначальные настройки отчёта (состояние Active наборов данных, и т.д.)
5. У TfrReport реализован метод SaveToXMLStream - сохраняем отчёт в произвольный поток в формате xml
6. В список объектов TfrObjectInspector также добавляется редактируемая страница отчёта
7. Для компоненты TLRSQLQuery реализован редактор свойства Database
8. Убрана переменная TfrDesignerForm.FileModified. Для признака модификации отчёта используется только переменная TfrReportDesigner.Modified
9. Перемнная TfrReportDesigner.Modified превращена в свойство
10. При изменении любого объекта в редакторе отчёта в строке статуса отображется сообщение о изменении
11. Для команд Save и SaveAs используется TAction - централизованное управление командами. Команда Save доступна только при изменении отчёта.
12. Исправлена ошибка сохранения свойства TfrObject.Visible - Сохранялось в виде числа, читалось как boolean
13. Переработана работа с параметрами для LRZQuery
14. Добавлена информация о лицензии в пакеты
15. Для окна TfrPageDialog правильно устанавливается заголовок окна
16. Исправлена работа скрипта для работы с TfrPageDialog - не устанавливались значения свойств
17. Реализован компонент TlrDBLookupComboBox
18. Исправлены ошибки дублирования текста модулей
19. Исправлено сохранение свойства frPage.PageType
20. Исправлено сохранение свойства frPage.Script
21. Исправлена ошибка - после вставки эелемента в отчёт не сбрасывался выбор на панели компонентов отчёта
22. Исправлена ошибка расчёта агрегатных значений
23. Исправлена ошибка изменения размера формы TfrPageDialog при изменении принтера по умолчанию
24. Перед печатью отчёта также исполняются скрипты объекта TfrPageDialog
25. Исправлено суммирование значенй в скриптах если суммируемое поле в БД = null
26. Minor bugfixes...
Additional InformationIt also should fix these bugs:
http://bugs.freepascal.org/view.php?id=22125
http://bugs.freepascal.org/view.php?id=22122
http://bugs.freepascal.org/view.php?id=22125
http://bugs.freepascal.org/view.php?id=22127
TagsNo tags attached.
Fixed in Revision37448
LazTarget-
WidgetsetGTK 2, Win32/Win64, Carbon, QT
Attached Files

Activities

2012-05-27 20:56

 

lr_v2-2012-05-27.rar (40,903 bytes)

Maxim Ganetsky

2012-05-27 22:16

developer   ~0060004

Fixed description.

Ihor Lavrynyuk

2012-05-28 08:33

reporter   ~0060007

Протестировал, все работает в ревизии 37440 + патч.
Если возможно посмотрите frTNPDFExport - он не работает с кириллицей(.

tested, all work revision 37440 + patch.

If you have wish, look frTNPDFExport not work with Cyrillic.

Ihor Lavrynyuk

2012-05-28 14:40

reporter   ~0060012

Last edited: 2012-05-28 14:44

C:\lazarus\components\lazreport\samples\userds not work correctly 37440 + patch.

and C:\lazarus\components\lazreport\samples\editor some time give error

Ihor Lavrynyuk

2012-05-28 15:10

reporter   ~0060013

Last edited: 2012-05-28 16:51

Только так работает динамическая вставка фото.
only this code work for insert pictures to report
procedure TfrmMain.frReportEnterRect(Memo: TStringList; View: TfrView);
begin
  if (View.Name='thumbnail') then begin
    TFrPictureView(View).Picture.LoadFromFile('C:\Users\root\Documents\ss\reports\noimage.jpg');
  end;
end;
----------------
this code not work, and any pictures data not add to report from tables
По полю bufDataset.FieldDefs.Add('image',ftBlob); или в сохраненной таблице ZTable... из базы данных не работает.
TBlobField(ds.FieldByName('image')).LoadFromFile(frmMain.program_dir+'reports\noimage.jpg');


issue.zip samples

2012-05-28 16:51

 

issue.zip (448,564 bytes)

Jesus Reyes

2012-05-29 06:48

developer   ~0060027

Applied, thank you.

@Ihor Lavrynyuk:
please don't report issues on "patch" issues, extra reports on same issue will be ignored because on resolving we are resolving the patch applying not the additional reports on same issue,

So please create separated bug reports and add relations to the related issues, I will give feedback about the problem with dbimage and images in that separated bug reports.

Ihor Lavrynyuk

2012-05-29 09:03

reporter   ~0060034

sorry me, yes you right, thank you, by you give experiences for me=)

Issue History

Date Modified Username Field Change
2012-05-27 20:56 Lagunov Aleksey New Issue
2012-05-27 20:56 Lagunov Aleksey File Added: lr_v2-2012-05-27.rar
2012-05-27 20:56 Lagunov Aleksey Widgetset => GTK 2, Win32/Win64, Carbon, QT
2012-05-27 22:14 Maxim Ganetsky LazTarget => -
2012-05-27 22:14 Maxim Ganetsky Description Updated
2012-05-27 22:14 Maxim Ganetsky Additional Information Updated
2012-05-27 22:16 Maxim Ganetsky Note Added: 0060004
2012-05-27 22:23 Maxim Ganetsky Summary Path for LazReport - continue work on DialogControls... => Pacth for LazReport - continue work on DialogControls...
2012-05-27 22:23 Maxim Ganetsky Summary Pacth for LazReport - continue work on DialogControls... => Patch for LazReport - continue work on DialogControls...
2012-05-28 08:33 Ihor Lavrynyuk Note Added: 0060007
2012-05-28 14:40 Ihor Lavrynyuk Note Added: 0060012
2012-05-28 14:44 Ihor Lavrynyuk Note Edited: 0060012
2012-05-28 15:10 Ihor Lavrynyuk Note Added: 0060013
2012-05-28 15:18 Ihor Lavrynyuk Note Edited: 0060013
2012-05-28 16:51 Ihor Lavrynyuk File Added: issue.zip
2012-05-28 16:51 Ihor Lavrynyuk Note Edited: 0060013
2012-05-28 18:56 Jesus Reyes Status new => assigned
2012-05-28 18:56 Jesus Reyes Assigned To => Jesus Reyes
2012-05-29 06:48 Jesus Reyes Fixed in Revision => 37448
2012-05-29 06:48 Jesus Reyes Status assigned => resolved
2012-05-29 06:48 Jesus Reyes Fixed in Version => 1.1 (SVN)
2012-05-29 06:48 Jesus Reyes Resolution open => fixed
2012-05-29 06:48 Jesus Reyes Note Added: 0060027
2012-05-29 09:03 Ihor Lavrynyuk Note Added: 0060034
2012-05-30 21:32 Lagunov Aleksey Status resolved => closed