View Issue Details

IDProjectCategoryView StatusLast Update
0022172LazarusIDEpublic2012-06-12 15:55
ReporterLudo BrandsAssigned ToMartin Friebe 
PrioritynormalSeveritymajorReproducibilitysometimes
Status closedResolutionfixed 
Product Version1.1 (SVN)Product Build 
Target VersionFixed in Version1.1 (SVN) 
Summary0022172: Division by zero when closing editor files
DescriptionClosing multiple files with Ctrl F4 raises sometimes a division by zero exception when in the middle of a debug session (breakpoint reached).
Trace attached with --debug-enable=DBG_CMD_ECHO,DBGMI_QUEUE_DEBUG,SRCED_LOCK,SRCED_OPEN,SRCED_CLOSE,SRCED_PAGES
svn 37471
Additional InformationRelated to 0022015: Division by zero when closing editor files
TagsNo tags attached.
Fixed in Revision37623
LazTarget1.2
WidgetsetWin32/Win64
Attached Files

Relationships

related to 0022015 closedMartin Friebe Division by zero when closing editor files 

Activities

2012-06-02 12:57

 

log6.zip (9,411 bytes)

Martin Friebe

2012-06-02 22:01

manager   ~0060184

Please test with 37486

Ludo Brands

2012-06-03 10:31

developer   ~0060210

Seems to work fine. Tried several times closing last editor window before the blue dots are shown. Watching the debug output confirms line numbers are received after the window is closed. So that problem seems to be solved.

Ludo Brands

2012-06-03 12:28

developer   ~0060215

thanks

Martin Friebe

2012-06-03 16:37

manager   ~0060227

Undone patch in r37501.

The changes caused issues with the internal queuing system

Martin Friebe

2012-06-11 20:55

manager   ~0060458

Please test and close if ok

Issue History

Date Modified Username Field Change
2012-06-02 12:57 Ludo Brands New Issue
2012-06-02 12:57 Ludo Brands File Added: log6.zip
2012-06-02 12:57 Ludo Brands Widgetset => Win32/Win64
2012-06-02 13:12 Martin Friebe Status new => assigned
2012-06-02 13:12 Martin Friebe Assigned To => Martin Friebe
2012-06-02 22:01 Martin Friebe LazTarget => -
2012-06-02 22:01 Martin Friebe Note Added: 0060184
2012-06-02 22:01 Martin Friebe Status assigned => feedback
2012-06-02 22:03 Martin Friebe Relationship added related to 0022015
2012-06-03 10:31 Ludo Brands Note Added: 0060210
2012-06-03 11:58 Martin Friebe Fixed in Revision => 37486
2012-06-03 11:58 Martin Friebe LazTarget - => 1.0
2012-06-03 11:58 Martin Friebe Status feedback => resolved
2012-06-03 11:58 Martin Friebe Fixed in Version => 1.1 (SVN)
2012-06-03 11:58 Martin Friebe Resolution open => fixed
2012-06-03 11:58 Martin Friebe Target Version => 1.0.0
2012-06-03 12:28 Ludo Brands Status resolved => closed
2012-06-03 12:28 Ludo Brands Note Added: 0060215
2012-06-03 16:37 Martin Friebe Status closed => assigned
2012-06-03 16:37 Martin Friebe Resolution fixed => reopened
2012-06-03 16:37 Martin Friebe Note Added: 0060227
2012-06-03 16:37 Martin Friebe LazTarget 1.0 => 1.2
2012-06-03 16:37 Martin Friebe Target Version 1.0.0 =>
2012-06-11 20:55 Martin Friebe Fixed in Revision 37486 => 37623
2012-06-11 20:55 Martin Friebe Status assigned => resolved
2012-06-11 20:55 Martin Friebe Resolution reopened => fixed
2012-06-11 20:55 Martin Friebe Note Added: 0060458
2012-06-12 15:55 Ludo Brands Status resolved => closed