View Issue Details

IDProjectCategoryView StatusLast Update
0022178FPCDatabasepublic2012-06-02 23:41
ReporterGökhan Engin Assigned ToJoost van der Sluis  
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionduplicate 
PlatformHandle TermOSWince 
Product Version2.4.4 
Summary0022178: Bus error or misaligned data access.
DescriptionLike me are getting this error when working with DBF files, a very simple solution.

respects

have a nice days.

Error :

****************************************************************************

Bus error or misaligned data access. Press OK to ignore data and risk data corruption. Press
Cancel to kill the program.

****************************************************************************

Solution :

Check the length of the field name in DBF files. (Max. Field length = 10 chars).
Note : usually exceeds the maximum value of the length of the field name automatically when creating DBF file.

ps: sample file sended.
TagsNo tags attached.
Fixed in Revision
FPCOldBugId
FPCTarget
Attached Files

Relationships

duplicate of 0022177 closedLudo Brands Bus error or misaligned data access. 

Activities

2012-06-02 18:08

 

sample.rar (1,254,667 bytes)

Bart Broersma

2012-06-02 21:16

reporter   ~0060180

Duplicate of 0022177 ?

Gökhan Engin

2012-06-02 23:41

reporter   ~0060193

Duplicate of 0022177

Issue History

Date Modified Username Field Change
2012-06-02 18:08 Gökhan Engin New Issue
2012-06-02 18:08 Gökhan Engin Status new => assigned
2012-06-02 18:08 Gökhan Engin Assigned To => Joost van der Sluis
2012-06-02 18:08 Gökhan Engin File Added: sample.rar
2012-06-02 21:16 Bart Broersma Note Added: 0060180
2012-06-02 22:06 Jonas Maebe Relationship added duplicate of 0022177
2012-06-02 22:06 Jonas Maebe Duplicate ID 0 => 22177
2012-06-02 22:06 Jonas Maebe Status assigned => resolved
2012-06-02 22:06 Jonas Maebe Resolution open => duplicate
2012-06-02 23:41 Gökhan Engin Status resolved => closed
2012-06-02 23:41 Gökhan Engin Note Added: 0060193