View Issue Details

IDProjectCategoryView StatusLast Update
0022211LazarusIDEpublic2012-06-11 10:54
ReporterTakeda MatsukiAssigned ToMartin Friebe 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version1.1 (SVN)Product Build 
Target Version1.2.0Fixed in Version1.1 (SVN) 
Summary0022211: [Patch] Source Editor : "Right-Click : Source -> Add Unit To Uses Section", failed to add selected unit into source editor
Description
After changes > r37466, "Similar" Issue with 22114 has back ( http://bugs.freepascal.org/view.php?id=22114 ). :(

I build IDE using "-O2 -g- -Xs" ("Optimized IDE" Profile) both for Compilation first-time and Rebuild the IDE, also I using Clean-Up mode : "Clean All".

I tested this issue with standard (default) packages installed in compilation first time (full fresh) + anchordocking installed and the IDE docked (like I did in issue 22114).


Regards,
takeda
TagsNo tags attached.
Fixed in Revision37567
LazTarget1.2
WidgetsetWin32/Win64
Attached Files

Relationships

related to 0022114 resolvedJuha Manninen Source Editor : "Right-Click : Source -> Add Unit To Uses Section", failed to add unit into "Interface" section 

Activities

2012-06-06 06:45

 

2012-06-06 - (SourceEditor) RightClick - Source - Add Unit To Uses Section [Patch].patch (512 bytes)
Index: sourceeditor.pp
===================================================================
--- sourceeditor.pp	(revision 37531)
+++ sourceeditor.pp	(working copy)
@@ -1309,6 +1309,7 @@
   if r then
     TIDEMenuCommand(Sender).Command.OnExecuteProc := nil;
   // Commands may not work without focusing when anchordocking is installed
+  ActEdit.Activate; // Activate first then make it focused
   ActEdit.FocusEditor;
   ActEdit.DoEditorExecuteCommand(TIDEMenuCommand(Sender).Command.Command);
   if r then

Martin Friebe

2012-06-06 09:12

manager   ~0060302

Last edited: 2012-06-06 09:53

Reproduced.

But looking at the that patch works, there is a deeper problem (meaning there may be other similar issues, or there could be with any future change)

  ActEdit.FocusEditor;
will focus the SynEdit. And that will call EditorEnter which actually calls Activate.

Takeda Matsuki

2012-06-06 14:08

reporter   ~0060307

Last edited: 2012-06-06 14:11

>> ActEdit.FocusEditor;
>> will focus the SynEdit. And that will call EditorEnter which actually calls
>> Activate.

Yes, but it failed to working properly. Seem it loose the "activate" control for their self.

In my test (at my home PCs), I changes the "FocusEditor" ways (changes this function), but this issue still come. So I revert it and add "Activate", then it back to work normal as before. ;)

I thought, this issue caused by the 'LockCommandProcessing' applied at new changes.

Martin Friebe

2012-06-09 22:05

manager   ~0060405

Have you tried with Revision 37567 (without your changes)?

Takeda Matsuki

2012-06-11 06:57

reporter   ~0060428

Okay, Now this issue has gone, Lazarus has working properly without this issue and this report can be closed.

Thank you so much, Mr. Martin And also to Mr. Mattias. :)

-takeda-

Issue History

Date Modified Username Field Change
2012-06-06 06:45 Takeda Matsuki New Issue
2012-06-06 06:45 Takeda Matsuki Widgetset => Win32/Win64
2012-06-06 06:45 Takeda Matsuki File Added: 2012-06-06 - (SourceEditor) RightClick - Source - Add Unit To Uses Section [Patch].patch
2012-06-06 09:12 Martin Friebe Note Added: 0060302
2012-06-06 09:13 Martin Friebe Status new => assigned
2012-06-06 09:13 Martin Friebe Assigned To => Martin Friebe
2012-06-06 09:13 Juha Manninen Relationship added related to 0022114
2012-06-06 09:22 Martin Friebe Note Edited: 0060302
2012-06-06 09:53 Martin Friebe Note Edited: 0060302
2012-06-06 14:08 Takeda Matsuki Note Added: 0060307
2012-06-06 14:10 Takeda Matsuki Note Edited: 0060307
2012-06-06 14:11 Takeda Matsuki Note Edited: 0060307
2012-06-09 22:05 Martin Friebe Note Added: 0060405
2012-06-10 13:22 Martin Friebe LazTarget => -
2012-06-10 13:22 Martin Friebe Status assigned => feedback
2012-06-11 06:57 Takeda Matsuki Note Added: 0060428
2012-06-11 10:53 Martin Friebe Fixed in Revision => 37567
2012-06-11 10:53 Martin Friebe LazTarget - => 1.2
2012-06-11 10:53 Martin Friebe Status feedback => resolved
2012-06-11 10:53 Martin Friebe Fixed in Version => 1.1 (SVN)
2012-06-11 10:53 Martin Friebe Resolution open => fixed
2012-06-11 10:54 Martin Friebe Target Version => 1.2.0