View Issue Details

IDProjectCategoryView StatusLast Update
0022438LazarusLCLpublic2014-01-29 06:18
Reportersamuel herzogAssigned Tosamuel herzog 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Platformwin32OSxpOS Versionsp3
Product Version1.1 (SVN)Product BuildLazarus 1.1 r37649 FPC 2.6.1 
Target VersionFixed in Version1.3 (SVN) 
Summary0022438: Changes to field-properties do not influence the IDE Save-button.
DescriptionIn the Object-Inspector I changed the property "Size" of a TField of a memdataset. This did not make the Save-Button in the IDE become enabled.
Additional InformationSteps to reproduce:

1.) extract the attached example.
2.) start lazarus and open the example.
3.) display the form and select the MemDataset1.
4.) Make sure "Save"/"Save All" Icons are disabled. (if not press on Icon Save All"
5.) click on property "FieldDefs". The Fields-Dialog will show up.
6.) select the field "Firstname" and change the property "Size".

You will see that the icons "Save"/SaveAll" remain "disabled", but they should be come "enabled" because we have applied some changes to the project.
TagsNo tags attached.
Fixed in Revisionr43040
LazTarget-
WidgetsetWin32/Win64
Attached Files

Relationships

related to 0024926 resolvedJuha Manninen save button does not enable after ... 

Activities

2012-07-15 13:01

 

2012-07-15 13:05

 

0022438_example.7z (60,839 bytes)

samuel herzog

2013-10-02 19:33

developer   ~0070493

Tested today with Lazarus 1.3 r43040 FPC 2.6.2 i386-win32-win32/win64.

Works now. Thanks.

samuel herzog

2014-01-29 06:18

developer   ~0072763

Thank you. I ok now. Tested with Lazarus 1.3 r43585 FPC 2.7.1 i386-win32-win32/win64

Issue History

Date Modified Username Field Change
2012-07-15 13:01 samuel herzog New Issue
2012-07-15 13:01 samuel herzog File Added: change_not_propagated_to_ide.jpg
2012-07-15 13:01 samuel herzog LazTarget => -
2012-07-15 13:01 samuel herzog Widgetset => Win32/Win64
2012-07-15 13:04 samuel herzog Summary Changes to field-properties are do not influence the IDE Save-button. => Changes to field-properties do not influence the IDE Save-button.
2012-07-15 13:05 samuel herzog File Added: 0022438_example.7z
2012-07-15 13:10 samuel herzog Additional Information Updated
2013-09-23 21:06 samuel herzog Relationship added related to 0024926
2013-10-02 19:33 samuel herzog Fixed in Revision => r43040
2013-10-02 19:33 samuel herzog Note Added: 0070493
2013-10-02 19:33 samuel herzog Status new => resolved
2013-10-02 19:33 samuel herzog Resolution open => fixed
2013-10-02 19:33 samuel herzog Assigned To => samuel herzog
2014-01-29 06:18 samuel herzog Note Added: 0072763
2014-01-29 06:18 samuel herzog Status resolved => closed
2014-01-29 06:18 samuel herzog Fixed in Version => 1.3 (SVN)